Released: Openhab2 Amazon Echo Control Binding (controlling alexa from openhab2)

development
binding
alexa
Tags: #<Tag:0x00007f0153ed2258> #<Tag:0x00007f0153ed1b78> #<Tag:0x00007f0153ed1448>

(Porthos) #1070

@michi thank you for reply and support. All is working fine with beta 5 and build #1409.
Wojtek


(CM6.5 H102) #1071

What OH version are you using?


(Lorenzo Giordano) #1072

Thanks with ver 5 now it works !!
Just one question:
I have an echo-dot and the textToSpeech seems does not work as expected.:
I copy the rule of you post but instead to repeat the writing message, the echo just say “sorry, I don’t find any answer to your question” (in Italian)… It seems it read the message as a Command ?!?.
Any advice to solve the issue?
Lorenzo


(Valerio Savioli) #1073

Hi i’m new.
I have intalled openhabian two days ago on rpi.
How can i get ver 5 work manually? I’m reading a lot of posts but i can’t understand how to do.
Thanks to all for your job.


(Kris K) #1074

Hi All

Started to see this error now, any thoughts?

18:07:02.940 [INFO ] [amazonechocontrol.internal.Connection] - Login failed: POST url ‘https://www.amazon.com/ap/signin’ failed: Not Found


(Lorenzo Giordano) #1075

Hi Valerio,
just copy the jar file in the addon directory in openhab.
if you need help also in Italian, send a PM
Ciao
Lorenzo


(Thomas) #1076

@michi
All is working good with snaphot #1346 and your beta (5).

Update: When I start openhab I always get this error message, but binding is working

    2018-11-04 17:19:26.531 [INFO ] [.handler.FlashBriefingProfileHandler] - FlashBriefingProfileHandler initialized
    2018-11-04 17:19:27.564 [WARN ] [mazonechocontrol.internal.Connection] - Parsing json failed {}
    com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_OBJECT but was STRING at line 8 column 1 path $
            at com.google.gson.internal.bind.ReflectiveTypeAdapterFactory$Adapter.read(ReflectiveTypeAdapterFactory.java:224) [16:com.google.gson:2.7.0]
            at com.google.gson.Gson.fromJson(Gson.java:887) [16:com.google.gson:2.7.0]
            at com.google.gson.Gson.fromJson(Gson.java:852) [16:com.google.gson:2.7.0]
            at com.google.gson.Gson.fromJson(Gson.java:801) [16:com.google.gson:2.7.0]
            at com.google.gson.Gson.fromJson(Gson.java:773) [16:com.google.gson:2.7.0]
            at org.openhab.binding.amazonechocontrol.internal.Connection.parseJson(Connection.java:700) [244:org.openhab.binding.amazonechocontrol:2.4.0.201811022124]
            at org.openhab.binding.amazonechocontrol.internal.Connection.getEnabledFlashBriefings(Connection.java:1058) [244:org.openhab.binding.amazonechocontrol:2.4.0.201811022124]
            at org.openhab.binding.amazonechocontrol.handler.AccountHandler.updateFlashBriefingProfiles(AccountHandler.java:575) [244:org.openhab.binding.amazonechocontrol:2.4.0.201811022124]
            at org.openhab.binding.amazonechocontrol.handler.AccountHandler.addFlashBriefingProfileHandler(AccountHandler.java:178) [244:org.openhab.binding.amazonechocontrol:2.4.0.201811022124]
            at org.openhab.binding.amazonechocontrol.handler.FlashBriefingProfileHandler.initialize(FlashBriefingProfileHandler.java:74) [244:org.openhab.binding.amazonechocontrol:2.4.0.201811022124]
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:?]
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:?]
            at java.lang.reflect.Method.invoke(Method.java:498) ~[?:?]
            at org.eclipse.smarthome.core.internal.common.AbstractInvocationHandler.invokeDirect(AbstractInvocationHandler.java:153) [94:org.eclipse.smarthome.core:0.10.0.201808242044]
            at org.eclipse.smarthome.core.internal.common.Invocation.call(Invocation.java:53) [94:org.eclipse.smarthome.core:0.10.0.201808242044]
            at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
            at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
......

Thanks!


(Valerio Savioli) #1077

Solved, just restarted openhaband check from console if new binding was active.
Once I’ve added a new thing, I’ve been able to choose the new binding.


(Michael Geramb) #1078

Hi,
Simple answer is no, this seems to be bug in the Italian version of the amazon SW. Other users of the iobroker reports the same.
But I have a question, what happen if you create a routine in the alexa app which should “Say” a custom text?
Best regards,
Michael


(Michael Geramb) #1079

New Beta Version 6

If you are using Beta 5, there is no need to upgrade. The new version fix the 2 factor authentication problem, which only occurs on new setup an account things. The second fix is the support for GZIP response of the amazon server. It makes the response size smaller, but I don’t think that this is a big advantage.

The problem which is reported for some echo dot devices in the TTS is not yet fixed. The problem for this issue is, that I could not reproduce the problem. But I work on this with an OH user from US.

You can download the new version from the top most posting.

Best regards,
Michael


(Michael Geramb) #1080

Thanks. Please sent me also the “Type” and “Family” code listed on the http://<youropenhab/amazonechocontrol/ page for the fire cube device.


(Lorenzo Giordano) #1081

Thanks Michael,
I don’t know what is a routine in Alexa … sorry.
If it is just send a text to the startRoutine item w/o the word “alexa” … it doesn’t work to me
Regards
Lorenzo


(Tommy Sharp) #1082

I’m running OpenHABian on the PI with 2.4.0 Build 1400

Should the Paper UI be showing some other details for the binding installed?

2018-11-05_121456


(Patrick Boch) #1083

Hi

just a short question, maybe I am on a wrong track here. I am trying to achieve the following with the echo control binding (great work on the binding, by the way): resume the current playlist (or a specific playlist).

I have the following in my rule:


   Echo_Keller_Provider.sendCommand("AMAZON_MUSIC")
    Echo_Keller_Titel.sendCommand("Setze Playlist xxx fort") (for non-Germans: "resume playlist xxx")


It does play the playlist in question, but instead of resuming a track where I paused it, it skips to the next track in line. Any idea why it does that or how I can achieve what I’m trying to do?

Thx
Patrick


(Adrian Bonacker) #1084

Hello,

I´m using the Bindings last Version downloaded from here and latest OH 2.3 and have a amazon.de account.

My Problems are the multiroom (WHA) Things. They are offline and i don´t know why they won´t go online. i added them from the inbox. when i log in to the amazon control website by http://openhabip:8080/amazonechocontrol/xxxxxxxx all devices are shown and behind the thing link of the WHA´s the channels are listed correctly.

does anybody know why my multiroom things are offline?
thx
adrian


(Markus S.) #1085

I have the same problem. Multiroom offline.
Greetings,
Markus


(Andrew Pawelski) #1086

@michi any chance you could add the beta of the binding to the marketplace and when ready roll the non beta out into the mainline?


(Adrian Bonacker) #1087

Woke Up this Morning an it worked…

Log says it got online at 5:40. maybe something changed on the Amazon Alexa website

Will try the Channels now.


(Mark) #1089

For those wanting to test Amazon Echo’s… Amazon gave me this link to a testing tool. It helped me get my German Echo’s changed over to English… might be useful here too?

https://echosim.io/


(Mr. Wiseman) #1091

How to question . . .

Here’s the situation I’d like some advise on . . .

I have a routine in Alexa called “Turn ON Fans” which calls the bondhome.io device to turn ON all the fans in the house; one at a time actually via Radio Freq. bondhome.io has NO binding as of yet; so the fans are NOT tied to any item in OH.

I also have a virtual switch on OH when pressed calls Alexa routine “Turn ON Fans” which intern updates the virtual switch to ON.

The problem I can’t figure out is when I tell, via a voice command, to Alexa to “Turn ON Fans”; how do I get Alexa to tell OH that these virtual switches should be turned ON?

If someone has figured this out; can you please provide detail instructions on how to :wink:

Best, Jay