Released: Openhab2 Amazon Echo Control Binding (controlling alexa from openhab2)

development
binding
alexa
Tags: #<Tag:0x00007f014c143968> #<Tag:0x00007f014c143828> #<Tag:0x00007f014c143648>

(Gabriele Siviero) #1113

I also tried again, but with the official PaperUI 2.3 addon and It now works again!


(Helmut Schütt) #1114

Hi,

I also switched back to “official 2.3.0” version. It works also.
I think it was an issue with the alexa login pages from amazon.

Regards

helmar


(omatzyo) #1115

This is exactly what mine do as well. I agree 100% with your assessment. I’ve tried using some timers when sending to the group, but that doesn’t seem to help:

Alexa_TTS_Alerts.members.forEach(item,i|createTimer(now.plusMillis(i*100)) [  | 
				item.sendCommand(sb_doors.toString)
				])

I haven’t tried removing the volume command before and/or after the command, have you?


(Thomas) #1116

Before giving up on that possible fix I suggest you experiment with larger timer values. I suggest you try 2000 millisec delay between each TTS voice command. That’s what I’m using on my trouble-free TTS rules (but as mentioned they are simpler rules that don’t change volume).

I won’t be able to do any troubleshooting until later next week. In the meantime, if you find a solution please share it here.

  • Thomas

(Michael Geramb) #1117

With the current BETA version is only one login necessary because it works in a complete different way. So you should update to the current beta.


(Michael Geramb) #1118

You could also try to use the new channel of the current beta to control the volume of TTS. Then the binding creates a routine which sets the volume, speak the text and reset the volume to the original volume


(Michael Geramb) #1119

This was a bug in amazon login page which happens for 2 or 3 days. The have created a wrong syntax in the url and so the proxy server did not work. Also the release version of the binding fails, if a login was necessary in this timeframe. But it seems the amazon have changed it back. So it should work again. I strongly recommend to use the beta version, because there is only one manually login necessary which is much more safe for the future.


(Thomas) #1120

Thanks for the suggestion. I would like to try this but cannot find any details on the required channel command or its syntax.

Is there a link to some examples on how to use the new channel method that sets volume, does TTS, then restores old volume? All I found was a reference to textToSpeechVolume in your release notes, but searching for its usage does not find anything.

  • Thomas

(Thomas) #1121

Comment to myself: I looked at the latest source code (in thing-types.xml) and now believe I understand how to use the new TextToSpeechVolume channel. I’ll experiment with it next week and report back if it solves my intermittent TTS voice error.

  • Thomas

(omatzyo) #1122

If you’ll enlighten me, I’ll also do some testing.


(Thomas) #1123

It appears the new TextToSpeechVolume channel is declared and used in the same manor as the existing volume channel. When your rule calls the TextToSpeechVolume channel all future TTS voice audio levels will be automatically changed to the TextToSpeechVolume value, then the old volume will be restored when the TTS message is done.

That’s my take on it. I could be wrong, so check the logs for related error messages if you run into problems.

  • Thomas

(omatzyo) #1124

This works well! I’ll have to simplify my rules. It also successfully plays most of the time. It still throws the error, as before, when I’m playing to the whole group, but only 1 or 2 devices. So, this is a huge improvement.


(Thomas) #1125

That’s very good to hear. I’m looking forward to trying it out.

  • Thomas

(Lorenzo Giordano) #1126

HI, Can you explain better how the routine works?

I have create with the Alexa app a simple routine caled “alexa, saluta” (Italian language)
The routine works if I say “alexa, saluta” to the echo, it says “benvenuto (welcome)”

now with OH:
from a rule I send : sendcommand(Echo_Living_Room_StartRoutine,‘saluta’) and the echo just play short noise…

Any help?
Regards
Lorenzo


(Michael Geramb) #1127

That’s not the normal behavior. Maybe it’s a problem of amazon.it?


(Platini76) #1128

I try with amazon.it

paper UI 2.30
and last beta of amazon echo control binding:
��Yks۸���_!q: ���%�


(Matt) #1129

Just tried to install. Won’t login and I get this when I go to the page to login.

��Yks����_Ab:4P@�$mhͱ-�u�Ʃ㤝QU�b�x�x)ɢ�{���K��N�T�ػw�޽ϳ�l��Na)ڻJΓ6�^���\d�i������c3�Gm� ��2H3i�C������e��LjyY�e�H��l>?M$_�NeQ�U;'��E+o��|�5���=��;yݮ��<�B���x+M�?=�l�U��&-��ƅ�4 �ln>&�iK��5��k�FO�c�5���:�D�C�frp�9��6��;3�]!


(Tom) #1130

Same here. No Login possible at the moment.


(Daniel A) #1131

I had the same issue. I had to update my openhab to the latest version. I had to download the latest binding from the top and manually install it.

I moved the binding to “/usr/share/openhab2/addons” and added permissions.

Not sure If i rebooted or manually installed in the openhab console

Also instructions are a little out of date. I didn’t manually add .things instead it auto discovers the items. No need to link serial numbers.

You then go in paperui to find the url that looks like this “amazonechocontrol:echo:4464634f:G090P301110418TH” and replace that line on the .items file.


(Chris Colden) #1132

Can someone please let me know how I’m suppose to install the beta from the post above? I’ve tried stopping openhab, clearing the cache, uploading into the addons folder and starting openhab again, but it still seems to pick the binding from the openhab2-addons package. Pulling my hair out, must be missing something obvious.

I’m seeing in the log that the url is no longer valid and hoping the beta has addressed this.

Thanks
Chris