Released: Openhab2 Amazon Echo Control Binding (controlling alexa from openhab2)

development
binding
alexa
Tags: #<Tag:0x00007f0144280fe0> #<Tag:0x00007f0144280dd8> #<Tag:0x00007f0144280b08>

(Leigh Saunderson) #1153

OK, my apologies, must have messed up a step earlier, and definitely didn’t clear the cache when trying the current beta version.
I’ve just uninstalled the snapshot binding via PaperUI, stopped OH2 , cleared the cache , put the downloaded beta in /usr/share/openhab2/addons (so now I have /usr/share/openhab2/addons/org.openhab.binding.amazonechocontrol_2.4.0.201811041600.jar).
Restarted OH2, and the Amazon Echo Control Binding was visible in Config/Bindings, but showing as “Install” when checked in Addons/Bindings (binding-amazonechocontrol - 2.4.0.SNAPSHOT).
Config the new version and it gave me the Alexa signin page, and I’m in, devices detected
thanks a lot, so anyone else seeing that page of non-text characters, try the current beta of the binding.
Now to go play with the dots !


(Mark) #1154

I also gave up with 2.3 and installed 2.4.0 instead. Account is now back online… Now I should spend some time checking out what is new in 2.4.


(E. Gerland) #1155

Hi David,

I recently verified that it’s most likely coming from amazon echo control on my system as well.

Without the binding, my system ran for several weeks without an error.
After activation it took 3 days until I saw the heap space issue:

2018-11-14 20:15:37.155 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'EventSubscriber.receive()' on 'org.eclipse.smarthome.core.internal.items.ItemUpdater@4c0be': Java heap space

java.lang.OutOfMemoryError: Java heap space

However, I don’t know how to verify if @4c0be is related to this binding… :frowning:


(tmn103) #1156

EDIT I removed the items and added them again. Having noticed that the PlayMusicCommand and TTS channels weren’t showing against the item in PaperUI.

This did the trick


I can’t get the PlayMusicCommand or TTS to work.

Using the latest version, the rule (updating message via MQTT) works, but no sound from the echo. Anyone else had this problem and fixed it?


(Mr. Wiseman) #1157

Echo DOT Issues:

For the last few months; none of my Echo DOT’s have worked. Our home setup has two Amazon accounts (wife and myself) which we have setup the Echo’s on both accounts.

Early BETA’s of Michael’s binding worked just using ONE of the Amazon accounts in the household.

For many months now; all my Echo DOT"s stopped working and the regular Echo’s continued to work. After working with Michael, I have discovered that a “household” with multiple Amazon Accounts does NOT work anymore across the board with all the Echo’s.

Once I singed on under my Amazon account; all the Echo Dot’s started working and the Echo’s on my wife’s account stopped working.

Amazon must of changed a security scenario for TTS across household accounts.

Bottom line; what ever Amazon account you setup your Echo with is the account you need to use for TTS. You can have multiple bridges for this binding if you have 2 or more Amazon accounts.

Best, Jay


(sujit) #1158

I am not able to login amazon account with OH 2.3 - beta 6
post providing correct credential in http://192.168.1.99:8080/amazonechocontrol/account1/ I am getting catch page
Post providing credentials one more time I am getting following page


(Daniel N.) #1159

I have the same Problem. :-/


(Stolly82) #1160

Me also


(Michael Geramb) #1161

Amazon have changed the login page. This causes the failure. It is fixed in Beta 7


(Michael Geramb) #1162

BETA 7

Whats new:

  • The problem with the changed login page from amazon is handled
  • New channel ‘announcement’

The channel announcement provides a feature which is only available in the alexa app of amazon.com. So I have no possibility to test it. It does not work with amazon.de, but maybe it works with amazon.com. You can send a text to this channel and this should push a announcement notification to the device.
Would be nice to get a feedback of amazon.com users if it is working.

Download link and a updated documentation is provided in the top most posting (Only tested with OH 2.3)
Would be nice to get feedback if it works with 2.4 too.

Note: This version have no more configuration values on the account bridge thing. If there any (provided in the thing file), the are ignored.

Best regards,
Michael


(Scott Karns) #1163

@michi, The beta 7 release is working for me, however, the new announcement channel does not seem to work. From my logs:

2018-11-16 14:14:15.170 [DEBUG] [mazonechocontrol.internal.Connection] - POST: {"behaviorId":"PREVIEW","sequenceJson":"{\"@type\":\"com.amazon.alexa.behaviors.model.Sequence\",\"startNode\":{\"@type\":\"com.amazon.alexa.behaviors.model.OpaquePayloadOperationNode\",\"type\":\"AlexaAnnouncement\",\"operationPayload\":{\"expireAfter\":\"PT5S\",\"content\":[{\"display\":{\"title\":\"OpenHAB\",\"body\":\"Just what you were waiting for, yet another echo announcement.\"},\"speak\":{\"type\":\"text\",\"value\":\"Just what you were waiting for, yet another echo announcement.\"}}],\"customerId\":\"XXXXXXXXXXXXX\",\"target\":{\"customerId\":\"XXXXXXXXXXXXX\",\"devices\":[{}]}}}}","status":"ENABLED"}
2018-11-16 14:14:15.681 [DEBUG] [mazonechocontrol.internal.Connection] - Call to https://alexa.amazon.com/api/behaviors/preview succeeded
2018-11-16 14:14:16.686 [DEBUG] [mazonechocontrol.internal.Connection] - Make request to https://alexa.amazon.com/api/np/player?deviceSerialNumber=9xxxxxxxxxxxxxxx&deviceType=XXXXXXXXXXXXX&screenWidth=1440
2018-11-16 14:14:16.980 [DEBUG] [mazonechocontrol.internal.Connection] - Call to https://alexa.amazon.com/api/np/player?deviceSerialNumber=9xxxxxxxxxxxxxxx&deviceType=XXXXXXXXXXXXX&screenWidth=1440 succeeded
2018-11-16 14:14:21.504 [DEBUG] [control.internal.WebSocketConnection] - Send Ping
2018-11-16 14:14:21.508 [DEBUG] [control.internal.WebSocketConnection] - Send message with length 98
2018-11-16 14:14:21.609 [DEBUG] [control.internal.WebSocketConnection] - Pong received

I am located in the US, so amazon.com is the domain for Amazon here.


(Thomas) #1164

@michi, I’m also a USA user and Beta 7 binding is working so far. I tried out your announcement channel but nothing happens. I think it is because I don’t fully understand what it does.

.items
String Echo_Office_Annc "Office Announcement" (EchoAnncGroup2) {channel="amazonechocontrol:echo:accountXXX:echoOffice:announcement"}

.rules
Echo_Office_Annc.sendCommand('This is a test of the Amazon Echo Announcement')

Test results: No errors, but nothing happens.

I am aware that Echo supports a verbal announcement feature (which works fine). But your new channel feature must do something else. Please provide more info and I will provide more feedback.

  • Thomas

(Michael Geramb) #1165

Please go in the Alexa App. Create a routine. Set any activation text. Add action. There should be an option with two speech bubbles as symbol. Choose this. Then you should have two options, the first send a notification to the mobile app, the second option is the magic thing. Please enter a text in the second option. Click to add the operation. Click to create the routine.
Now you should be in the routine overview page. Go back to the newly created routine. In the menu in the top right corner should be the possibility to test the routine.
Please tell me what’s happen.


(Markus Rohe) #1166

Hi michi
i tested Beta 7 with amacon.de…ans it worked fine at the moment.
But one thing i found it dosent work in all Versions.
Alexa dosend accept the “startroutine” command.
in the past the command workt very well an i used it to control my IP Plug In´s
In the past it workt in the items with a “String” now i read in the Binding description that this Item is a switch.
Have you tested this Item in your Binding as well or have you an answer for me.
Thank you for you help

Best regards from Germany
Markus


(jw82@mail.de) #1167

The actual in Openhab 2.4.0.M5 integrated Amazon Echocontrol Binding isnt working, too (login results in cryptic Website.

What i did to fix it:

  • uninstalled the Amazon Echocontrol Binding via PaperUI
  • downloaded the Amazonechocontrol Binding Beta 7 (xxxxx.jar file) from here
  • put it in the /addons folder
  • opened 192.168.1.240:8080/amazonechocontrol and logged in

and … it works! Thanks Michael!


(Ben) #1168

Michael,

Just want to say a MASSIVE thank you for your work, I’ve finally have spoken notification on my Echos and want to take it step further, I want Alexa to ask me questions when I enter each room with some simple rules, alternatively, using a dialogue based skill… Do you know what would be the quickest route for me to activate the listening mode on Echo (basically simulate speaking the wake word or alternatively pushing the button)? Is it possible to achieve this via openhab2 binding?

Ben


(Thomas) #1169

@michi, thanks for the clarification on the new announcement feature. It works when the routine name is spoken to an echo. But when I use the channel function I am not getting anything.

I have routine named “paulie” and the rule contains this:
Echo_Office_Annc.sendCommand(‘paulie’)

It seems I am not using the corrent command syntax. What is the correct format?

  • Thomas

(Kris K) #1170

Hi Guys

Does anyone know if its possible to in a rule, play a WAV file to a particular Echo Dot using the binding? If so, how? i have alarm.wav stored under /etc/openhab2/sounds

Thanks!


(JustAProgrammer) #1171

Anyone else having problems recently? Echo dots and Account is offline and login WebUI not reachable


(Thomas) #1172

My USA (amazon.com) account has been working fine.

  • Thomas