Released: Openhab2 Amazon Echo Control Binding (controlling alexa from openhab2)

development
binding
alexa
Tags: #<Tag:0x00007f01535f6850> #<Tag:0x00007f01535eb928> #<Tag:0x00007f01535ea7f8>

(Thomas) #1173

See my Nov 14 posting.


(Peter Mueller) #1174

My German amazon account just crashed my sitemap. Nothing has been changed. My OpenHab is pretty robust, running for months. When it crashes sometimes, its most often caused by this binding.
Today, I had to reboot Openhab and everything fine. But amazon account still not running.


(emik) #1175

Yes my German account cannot log in as well: “What are you looking for” after login. 2-factor Auth is now enabled again, but with less “complex” characters.

Seems like the API-hook method is probably not the most stable? Sad that amazon changes the API so often lately….


(Russell Green) #1176

Greetings,

How does one override the default Amazon Echo binding and replace it with your 2.4 beta? I’ve copied the jar file to the …/addons directory but I still only have the option to install the 2.3.0 version from the PaperUI

Am I missing a step? The entry @ http://openhab:8080/paperui/index.html#/configuration/bindings/amazonechocontrol Doesn’t disappear when I uninstall.


(Mr. Wiseman) #1177

Same here in the US; I have 3 Amazon accounts connect to my OH.

Best, Jay


(Thomas) #1178

The manually installed binding will not appear in PaperUI. No worries.

Use PaperUI to uninstall (disable) the old default binding. Confirm it shows the binding is not installed before placing the new jar in addons.

It has been suggested to rename the jar with a standard name that you will continue to use with each new release. This helps prevent multiple instances of the binding if future versions are installed.

The manually installed jar will ignore PaperUI and get loaded at reboot because it is in the addons folder.

  • Thomas

(Matthieu Lauzon) #1179

All is working here with OH M.6 and the beta (7) of this binding . Thanks a lot @michi

Edit: I am on amazon.com . But live in Canada


(Wolfgang Rosenauer) #1180

My Amazon stopped working recently as well so I checked here.
I’m running 2.4.0 SNAPSHOT right now after I updated this morning and bundle:list shows
237 │ Active │ 80 │ 2.4.0.201811212219 │ Amazon Echo Control Binding
Since the referenced beta7 build version is older does the snapshot version contains a possible fix or not?

And if not, how can I convince openHAB (in best case during runtime) to replace the preinstalled one with an “older” one in addons?


(nively) #1181

Dear all I am a newbie of openHab,
I have followed the instruction to install the beta version and I am able to see the login page but
After I log in I reach this page

Anyone had the same problem?

Thanks
Dev

P.S. I live in France, is Amazon.fr supported?


(Angelos) #1182

No, the snapshot includes whatever has been merged into the main distribution. The last update to org.openhab.binding.amazonechocontrol on the distro was done 2 months ago.

The beta (7 at this moment) from the first post is much more updated (even if it has an older timestamp on it). Filename: org.openhab.binding.amazonechocontrol_2.4.0.201811161948.jar

You need to uninstall the one that comes with the snapshot build and install manually the beta in your addons folder (in linux: /usr/share/openhab2/addons/)

In PaperUI -> Add-ons -> Bindings you will see the snapshot as uninstalled but that’s fine

You can check if the binding has been installed and activated by using the console:

bundle:list -s |grep amazon

only 1 (Active) entry for amazonechocontrol should appear with this command


(Jamie Temple) #1183

Same problem here in the UK… :frowning:

… it looks like Beta 7 is only working for users with Amazon accounts registered in Germany (amazon.de) or the US (amazon.com) …

… the joys of beta software … I’m waiting to see what Beta 8 brings :slight_smile:


(Michael Geramb) #1184

Hi, it would be nice to get more information, otherwise beta 8 and the release will have the same problem because I can only test with my german account. The most important information would be the url what the browser shows on the error page.
Best, Michael


(Michael Geramb) #1185

The beta 7 is the newest version, the snapshot build does not contain any fixes because the are not merged yet from the project owners.


(Michael Geramb) #1186

That is a very interesting case. Could you checkout the /amazonaccount and click on your account. Does the binding show the correct domain (alexa.amazon.com)?


(Michael Geramb) #1188

Hi, if the url in the browser does say some like ’ https://www.amazon.com/ap/maplanding[...] you can try to change the url as workaround to http:///amazonechocontrol//ap/maplanding[…]
I will try to fix this with the next version. It seems that the proxy server does not replace this url.

Best regards,
Michael


(Tobus) #1189

Hello Michi,
thanks for that Binding, its so great!

I have one question. I installed the current beta of the link above. Some channels are missing, eg. the textToSpeech.

Can you tell me, what I have to do exactly to get all channels? (I’m using the current Echo Dot)

Thanks a lot
Tobias


(Wolfgang Rosenauer) #1190

Thanks for the clarification. I already had beta7 installed but it was overruled from the snapshot installed one. After uninstallation it just works. Thanks for the update so working fine for me again.


(CM6.5 H102) #1191

Try clicking on the “Show More” button, see example below on right side.


(Tobus) #1192

Oh yes … Thanks!!


(Tobus) #1193

Good morning,
I tried that Echo says the state of an Switch (on or off), but it works different to eg. TelegramSend.
Does somebody knows, how to do following correctly? (because that doesnt work in this way. Echo tells me only “Alarmanlage S”)

   AmazonEchoDotWohnzimmer_Speak.sendCommand("Alarmanlage %s", Alarmanlage_Switch.state.toString)

Thanks
Tobias