Released: Openhab2 Amazon Echo Control Binding (controlling alexa from openhab2)

Tags: #<Tag:0x00007fe0635fdea8> #<Tag:0x00007fe0635fdd68> #<Tag:0x00007fe0635fdc00>

(Karl Heinz Weidlinger) #1254

Hello, I get the following picture when setting up AmazonEchoControl when I click on Login. What can I do there?
tmp and cache already deleted, no change.

(Scott Rushworth) #1255

(Karl Heinz Weidlinger) #1256

yes many thanks that worked now

(illnesse) #1257

Just FYI, My net seems to have gone down last night and as a result the echo control binding was spamming errors & warnings like crazy, over 1000 failed connection attemtps and related log messages for about 2 hours straight.

2018-12-06 03:15:01.294 [WARN ] [mazonechocontrol.internal.Connection] - Request to url '' fails with unkown error

2018-12-06 03:15:01.598 [WARN ] [mazonechocontrol.internal.Connection] - Request to url '' fails with unkown error

2018-12-06 03:15:01.694 [INFO ] [mazonechocontrol.internal.Connection] - Error getting device notification states {}

2018-12-06 03:15:01.772 [WARN ] [mazonechocontrol.internal.Connection] - Request to url '' fails with unkown error

Memory usage went through the roof as well, see

The yellow block is the 2 hours worth of warning spam, during which the OH2 memory consumption climbed up to 900MB (from around 600MB, which is normal for my RasPi 3B+) Any chance of getting the requests a bit under control if there is no working internet connection?

(Michael Geramb) #1258

Please define it as echo thing and give me feedback which channels are workung

(Lars) #1259

Is it possible to add the “DontDisturb”&“Disturb” commands somewhere in this binding?
Maybe with the “startCommand” channeltype?

(Paul ) #1260

How do you add the latest version after the .jar is downloaded? Thanks in advance

(Flip) #1261


I downloaded the latest Beta (org.openhab.binding.amazonechocontrol_2.4.0.201812011454.jar) and installed it. Now the amazon-Login-Screen appears when I go to amazonechocontrol. Unfortunately it comes up with an error after I log in. The link looks like (I modified some values - e. g. my token):

The page is saying:

Looking for Something?
We’re sorry. The Web address you entered is not a functioning page on our site

Any idea?


PS: I’m located in DE but the link above shows

(Flip) #1262

Hi Paul,

just put the .jar-file in the addons-folder ( you can find an overview of the file structure here: ). Then I changed the owner (chown openhab:openhab xxx.jar) and set rights to rw/rw/r (chmod 664 xxx.jar). Afterwards I restarted openhab. Please not that the Binding will not appear in Addons-section of Paper-UI. But if you look into the Bindings, you can see it.

If you wanna be sure, you can check console:

openhab-cli console
(default password is habopen)

bundle:list -s

and watch out for the Active Binding.


(Eyal Cohen) #1263


Can Echo be an audio sink (so I can use playSound)?

(Michael Geramb) #1264

No, only the predefined alarm sounds can be played.

(Michael Geramb) #1265

That part is ok, the app login goes always to It seem that for some users the proxy server of the binding can not replace all urls and so it ends on the amazon server. Could you make the login again and save the html-pages of all login steps. If the url in the browser switch from your openhab to amazon, I would need the page before (Please remove private informations or sent it as PN).

(wildzone) #1266

I upgraded to the latest beta by placing the jar file into the addons folder.
The account Thing is not created. How do I create it?

Thank you!

(wildzone) #1267

Never mind, just found it. Simply add it with the + symbol in the inbox menu

(Michael Geramb) #1268

This would be possible, but it is not yet implemented in the binding. But it should be possible to do it with a rest call (not tested) to the proxy server of the binding.

PUT http(s)://<youropenhab:yourport>/amazonechoncontrol/<youraccountthingid>/PROXY/api/dnd/status

e.g.: http://localhost:8080/amazonechoncontrol/account1/PROXY/api/dnd/status

with the json:

The device type and serial can you get from this page http(s)://<youropenhab:yourport</amazonechoncontrol/<youraccountthingid>

Would be nice to get feedback if this is working.

(Michael Geramb) #1269

Hi Rainer,

The problem for this is, I have no good idea how this information can be provided in channel. Do you have any suggestion?

But you could use a REST call to get the informations about alarms.



Best regards,

(Michael Geramb) #1270

Hello All,

The BETA 2.4 (9) is now merged in the master and is included in the daily snapshot builds starting from today.

Best regards,

(Lars) #1271

thx for your answer. i am happy, that there could be a way to do this.

i tried to test this. But POST requests (in a external tool) are not so easy like GET in browser i guess, because of session-handling…

So i figured out a way, to do POST-requests in chrome-browser.

I typed in chrome-console:

fetch('http://openhab:8080/amazonechocontrol/[myaccountid]/PROXY/api/dnd/status', {
method: 'POST',        
headers: {
  'Accept': 'application/json',
  'Content-Type': 'application/json'
body: JSON.stringify({deviceSerialNumber: '[myserial]', deviceType: 'ECHO', enabled: true})
.then(function(res){ console.log(JSON.stringify( })

but i got a error 500 back…in postman and also in chrome…hmmm

(Michael Geramb) #1272

No, session handling is done by the binding proxy. But yes, you can not make a simple POST in the browser without any tool. My favorite tool is postman.

The deviceType is wrong. Echo is the type in my binding. It must be the code from amazon shown in the family column in the binding.

(Michael Geramb) #1273

No for me because I’am not a java expert. But maybe anyone else can take a look in the code:

The requests are started in the makeRequest function in line 411. Or the websocket connection

But none of them should cause memory leaks.