Reliably switch KNX devices

I switched from OH1 to OH2 last week. My observation with OH1 was, that sometimes KNX devices don’t switch although the regarding rule fires. OH doesn’t handle the missing state change.
With OH2 I hoped to get rid of this, but unfortunately I found this behaviour as well.

My observation:
In my event.log a correct switching action looks like this (1. command received and 2. state changed):

2017-02-14 05:17:36.756 [ItemCommandEvent          ] - Item 'MusikWCBalkonSchalten' received command ON
2017-02-14 05:17:37.064 [ItemStateChangedEvent     ] - MusikWCBalkonSchalten changed from OFF to ON

When it fails, the status change is missing. There is just the received command.

2017-02-14 05:17:36.756 [ItemCommandEvent          ] - Item 'MusikWCBalkonSchalten' received command ON

Obviously KNX didn’t send the state back to the status ga. It seems, the knx binding doesn’t handle this.

Is there a way to enhance the binding, to take care of a reliable switch (to watch for the state change)? Is there a way to retrigger if a switch fails?

Thanks and regards,

Edit: the regarding KNX device (MusikWCBalkonSchalten) was switched OFF before the rule tried to switch in ON. So there should have been a state change, when KNX would have switched.


Can you please post the item declaration from the items file with the KNX binding ga’s?

Best regards,


Hi George,
this is the item definition:

Switch MusikWCBalkonSchalten "Verstärker WC/Balkon" <audio> (gWC,gBalkon) { knx="1/5/10+<3/5/10" }

Kind regards,

Am I the only, who has this problem? Unfortunately it happens not to seldom, that KNX switch actions are dismissed. In general everythings works fine, but sometimes - without any obvious reason - KNX switch actions don’t happen.
I think, that openhab should be able to manage this, as - if items are correct defined - the KNX response state should be taken into account. In my cases, no knx response commits the switch action, so openhab should retrigger this action after some timeout. In this case the state of openhab definately differs from the real state, which should be avoided.

This item should get a response on status GA (<3/0/12):

Switch SchlafzimmerSchalten "Licht Schlafzimmer" [ "Lighting" ] { knx="1/0/12+<3/0/12" }

In knx.cfg there is a timeout=10000, but I think this isn’t responsible for my wished behaviour, isn’t it?

Is this an enhancement for the KNX binding? Or is there a parameter/switch in knx configuration, I don’t know about? Would be nice to get some response. Thank you.

No ideas?
Is my request a feature enhancement for the knx binding?