Remote access to OpenHab2 not working [Solved]

Dear All,

First of all, thank you for this amazing piece of software and the effort you put into it.

I was previously using Openhab 1 with no particular problem. I recently upgrated to Openhab 2 and it went quite OK except for the remote (4G) access from my iPhone (wifi works). When I disable wifi on my iPhone (5C) and I try to lauch Openhab iOS client it says "connecting to remote URL but nothing happens.

I use the following remote url and on my router this port is redirected to my Pi2 server (which has the right java version). Under a web browser, I have a certificate warning but if I accept the exception I then have access with no problem so I guess this has to do with SSL and user authentication but I am not getting any error message.

I have unsuccessfullsy searched the web to find out how to configure the user and password in Openhab2 on the server side. My is online and I think I have tried every possible combination of iOS client setting (SSL certificate, timeout,…)

Has anyone already met this situation? if so could you please help on fixing it?

Thanks in advance.


It is not an openhab solution but the following does the job