Remove a ghost Z-Wave Node from HABmin

Tags: #<Tag:0x00007f61847b2c70> #<Tag:0x00007f61847b2ab8>

Hi all,

so is there a solution now? because I also have the same problem with this “gost” nodes.
In my case it is like 1 powered a node and found it trough Habmin, but then I didn’t added it as a thing.
I unpowered the device an deleted it from the inbox but if I do a search for new devices every time I get this device. But it is powered off. I also tried the way with setting as failed and remove from controller. Same behavior. I’m on the new snapshot 2.5.0.201905191822 from yesterday.

If you don’t have solution yet, I can also provide you a log if its helpful?!

Same problem here.

Stupid question - how to add the node to the dead list? The only options in Habmin which I have under advance list are:

  1. remove
  2. set as failed
  3. reinitialize
  4. heal

Cloud you guys be so kind and explain step by step how to do that?

Thank in advance

  1. Set as failed
  2. Wait 20-30 s.
  3. Remove from the controller
  4. Restart the Openhab server
  5. Find your device on the things list (it would have some kind of remark like “…Z-wave network…” < don’t remember exactly.
  6. Delete the thing.
  7. You made it :slight_smile:

Unfortunately that does not work for me.
Did exactly the steps from above but still with DEBUG logging on for zwave I see activity that stuff is sent to the node which is obviously not responding. Also all things coming back into the Inbox.

openHAB 2.5.0~S1637-1 (Build #1637) on openhabian on Raspbian 9.

Since I’m using a Razberry module I cannot use any other tools to get rid of the stuff and those Fibaro wall-plugs lose their connection every few months :frowning:

As far as I understand, you can not remove a node by the use of habmin, if the device doesn´t communicate. You´ll have to use a special tool for this, which I have forgotten the name of. And then you´ll be removing the node directly from the z-wave controller.

It’s called the Z-Wave PC Controller. There’s a link in this post.

To be frank, zensys is garbage. The link to the software leif has mentioned is far far better and actually works properly.

Repeating a Windows tool does not help in any way because my controller is a RPi module and NOT a USB device. Does anyone know of a tool which runs on an RPi with Linux to access the controller in such a way?

If you mean the RaZberry card (you need to tell!) then you can use Z-Way, downloadable on zwave.me.

2 Likes

z-way finally did it.
Thanks for the pointer.

And I told in my first post :wink:

Since I’m using a Razberry module I cannot use any other tools to get rid of the stuff

1 Like

Hi @Wolfgang_Rosenauer

That really sounds promissing!
I’m trying to get rid of ghost devices since a long time without success.

The current installation on my Raspberry Pi is:

  • openHABian Configuration Tool [master]v1.4.1-466(0824b76)
  • Release = Raspbian GNU/Linux 9 (stretch)
  • Kernel = Linux 4.14.79-v7+
  • Platform = Raspberry Pi 3 Model B Rev 1.2
  • openHAB 2.4.0-1 (Release Build)
  • 234 │ Active │ 80 │ 2.4.0 │ ZWave Binding

I’m not sure about this instructions:

  1. Do I have to do some deinstallations or preparations first or can I just start the installation of z-way on my Raspberry by following this instructions?
  2. Instruction: After upgrading clear browser cache and cookies . => On my Windows Pc?

Would you please briefly describe how you managed it?
Thanks in advance!

I just copied the Z-Way Raspberry Image on a different SD-Card, stopped the system and booted via the Z-Way SD-Card.
After finding the Z-Way webinterface there was some advanced configuration screen somewhere where it was possible to remove failed devices. It took me a bit of search in the z-way interface but I eventually found it. Unfortunately I already do not remember anymore where I exactly needed to go within the interface. I did not do any other setup within z-way. Just gave it enough time to recognize all devices and find the ones which did not react anymore.

Okay, using a different SD-Card! :bulb:
Did not think of that.
Thanks a lot. I will try that.

You do not need a different SD-Card, just stop OH and install and start Z-Way.
Before restarting OH simply stop Z-Way :slightly_smiling_face:

Hi,
sorry but I can’t find a way to remove a dead node from my controller. There is no real problem now, but it would be nice if I can remove the node.

I tried to set the node as failed in HABmin. This is the debug log:

But the device is now NODE 34, not 33. Why the log tells me my node are healthy?

Later in the log appears this messages:

21:14:01.210 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 33: Polling...
21:14:01.211 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 33: Polling deferred until initialisation complete

I try for several days now without success.
OpenHAB is 2.5M3 since today, before it was M2.

So, any idea what to do?
Of course I can remove the Stick from server and plug into my workstation te use another zwave tool, but first I want to remove the dead node with open hab if there is a way.

The device is a fibaro smoke sensor (FGSD002). The (default) wakeup Interval is 21600 s.

Thanks,
Daniel

I think @chris said if you mark the Thing as failed in HABmin the controller may remove it.
Of course, you then need to delete it from HABmin after some time.

You can’t remove nodes that are working - the controller will not let you. If the node is working, then you should simply exclude it from the network.

If the node is not working, then you need to mark it failed - the controller will only allow you to do this if the controller thinks it really has failed. Once it is in the controllers failed node list, then you can send the command to remove the device.

Thanks @chris and @Bruce_Osborne for your answer,
The device is resettet and reincluded as node 34, so I can’t exclude it regulary from controller.
So I tried exacty what chris said, I tried to set the device failed in HABmin.
What can be the reason that the controller think the device is working? It isn’t.
I own only one Fibaro Smoke Sensor.
I’am realy confused.

I had no success using either habmin nor paperui to get rid of failed (ghost) nodes with my Razberry. I just used Z-Way server (that i installed and deactivated on my rpi). It worked like a charm, no dead devices anymore. I don’t know what’s the problem with Razberry and openhab, but I cannot exclude devices and I can’t remove nodes from the controller.

As far as I know, you cant use neither Habmin or PaperUI to remove ghost nodes. Both options require that the connection to the device is working (online) which isnt the same as a ghost node. When the device isn´t online, PaperUI or Habmin cant remove the node.
At least thats how I understand it. @chris may know more.