Replacing dead z-wave devices

Hi all,
My Pi4B system, still running OH2.5.9 files only, ran into a dimmer issue a week ago because a NEXA ZV-9101 puck dimmer died.

A new NEXA was purchased, but it seems impossible to get it going. The Inclusion seems fine on a new Node number. I have access to all 3 Items and correct commands appear in the log, but no light.
I have tried everything I can think of including the old polling time trick (3000ms). And NO!! the bulb is not dead.

The only difference I can find between the dimmers is the Firmware number. The old is 1.5 and the new is 1.8.

I guess Firmware is a parameter in the Z-Wave database, but can I tweak my OH2.5 to make it work (a file update/tweak)? I’m a bit lost right now.
Any suggestions?

Some devices do use the firmware to differentiate, but it does not appear your device does (i.e. DB entry is for all versions) .

Maybe try Debug?

Hi Bob,
Thanks for responding. Not much help though.
I’ve been debugging for days and I’m completely lost in the woods, and it’s dark out there too.

Anyone else having bad experience with dimmers and have suggestions?

Hei, Bjørn :wink:

Do you have any ghost nodes?
Ghost nodes can result in trouble…
If the dead nodes come back when doing a “scan” (when deleted in UI),
you have gjost nodes.
I did manage to remove two ghost nodes only using the z-wave binding.
But my OH is running v.3.3 …

I was referring to log:set DEBUG org.openhab.binding.zwave . If that has been what you have been doing I apologize. :wink:

I would be willing to look at the output (in code fences) for a second pair of eyes. Also the zwave viewer tends to pick out the main items of why something is not happening

Thanks Nils,

Nope. Removed by the zensys tool.

Thanks Bob,

Nope, I have never tried that debugging tool. Good suggestion. I’ll look into that.
My thinking has been that the code has been running flawlessly for more than a year. The only thing I did was to swap the dimmer, include it and change the channel node number for the old Item name.
How much damage can that do?
Frustrating… rrrrrrr