Repository issue on Debian for Snapshot

linux
error
install
Tags: #<Tag:0x00007f0152f66da0> #<Tag:0x00007f0152f66a30> #<Tag:0x00007f0152f66828>

(pflodo) #1

I have installed the Beta using the repository fine, and I have installed snapshot manually, but I cant get snapshot installed from the Cloudbees repository.

I recreate /etc/apt/sources.list.d/openhab.list as per: http://docs.openhab.org/installation/linux.html

I have problem when updating the repository, and it complains it can’t find Packages (404)

Err:9 https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-offline/target/apt-repo  Packages
  404  Not Found
Ign:10 https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-offline/target/apt-repo  Translation-en_AU
Ign:11 https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-offline/target/apt-repo  Translation-en
Err:12 https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-online/target/apt-repo  Packages
  404  Not Found
Ign:13 https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-online/target/apt-repo  Translation-en_AU
Ign:14 https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-online/target/apt-repo  Translation-en
Reading package lists... Done
E: Failed to fetch https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-offline/target/apt-repo/Packages  404  Not Found
E: Failed to fetch https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-online/target/apt-repo/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

If you stick https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-online/target/apt-repo/Packages.gz
in your browser or I use wget on the server itself, it finds it fine (200 OK).

I don’t get it…


(pflodo) #2

Is anybody using Debian (Stretch) for OpenHab?

I am trying to figure out if it is something to do with my particular installation, the OS, or the repository.


(Monkey Trumpet) #3

I’m having the same problem, did you ever resolve this?


( ) #4