[Resolved] After upgrade to 2.5.5 roller shutter group in sitemap stops working

Tags: #<Tag:0x00007f617fe875f0> #<Tag:0x00007f617fe87320>

Apologies if the answer is obvious - I did search diligently :slight_smile:
Had a working Sitemap in 2.5.3 per below

	Frame label="Shutters" {
		Switch item=Shutters icon="rollershutter"
	}
	Frame label="First Floor Shutters" {
		Switch item=FirstFloorShutters icon="rollershutter"

Shutters & FirstFloorShutters above are RollerShutter groups.

After upgrade to 2.5.5 the sitemap displays a switch instead of the UP-BUTTON-DOWN icons and, more importantly, the command issued when clicking is a switch ON/OFF.

In 2.5.3 it was displaying the right icons and sending the UP/DOWN/STOP commands to the group.

If I use Default instead of Switch in the sitemap I get the individual members of the group displayed properly and can control them individually but not as a group.

Do I have to use mappings now to create it?

Which UI, please? And could you confirm exact type of your Group(s)?

Instead of Switch have you tried Rollershutter?

Frame label="Shutters" {
		Rollershutter item=Shutters icon="rollershutter"
	}
	Frame label="First Floor Shutters" {
		Rollershutter item=FirstFloorShutters icon="rollershutter"

More information on Items can be found in the link

Basic UI & IOS App - exact same behaviour
The Groups are type Group and all members are type Rollershutter

Okay, you should define your Group as type Group:Rollershutter

Just tried it and OpenHAB barfed :slight_smile: on Rollershutter

loop did not match anything at input 'Rollershutter'

Unfortunately.

Yes, there is no Rollershutter widget in sitemaps.
The Switch widget should recognize when a Rollershutter type Item is called, and render shutter buttons.
A Group would need characterizing as a Rollershutter type Group.

Ah - I thought Groups inherited their properties from their items. Will test tomorrow and report.

No, you have to be explicit for a Group’s “sub-type” - it may have members of several different types (including more Groups)

Ok that works - so now we have to give explicit sub-type to the Group. Wonder why it was working in 2.5.3 w/o it :wink:

This is not a new requirement, it’s from early openHAB-1. I cannot imagine how it ever worked before.

Probably slipped through the cracks - makes sense to be the way it is

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.