REST Api not working properly

Platform information:
Hardware: Mac Mini 2012
OS: High Sierra
Java Runtime Environment: Zulu 8u163
openHAB version: 2.3
Issue of the topic:

Rest API shows item conditions when requesting state properly.
When i send out commands and read them back it is changed as desired but:

Nothing happens at all. For example: A light switch. I read and it’s on. When i send state OFF and read state again, Rest Api says it’s off but the actual light does not change. Even logs say that the item has been changed:

2018-06-01 20:26:30.928 [vent.ItemStateChangedEvent] - WoZi_Licht_Esstisch_Schalter changed from OFF to ON

Same is true for every other item i tried …
Something is not firing and i don’t know where to search …

I do have a lot of issues because i transferred my system and i am trying hard to solve them myself but i have no idea what i can do here …

What REST command and URL are you using to command the light? It is important to understand the difference between a command and an update and use the correct REST HTTP command (POST for commanding an Item).

See https://www.openhab.org/docs/configuration/rules-dsl.html#scripts

1 Like

Thanks a lot Mr. Koshak!

Your guess was right. I was indeed using the wrong option (update instead of Post)! I will read the linked Article tomorrow! Thanks a lot!
The only thing i can not understand right now is that everything worked with the update command in oh 2.2 on my pi … :wink: