Rest api stopped working after update 2.4

Tags: #<Tag:0x00007f616f661020>

Hey
I have just updated to 2.4 from 2.3 and having some issues.
Firstly everything looked good and smooth, no errors in openhab.log. I tried to use the rest api, but no response. I can see that the the system detects the call, there is a line in the logs which represents the received command, but no line (and no real action) for item change. I got back the 200 response code and the device’s network status is online (log says).

I tried to delete cache but I cannot stop the system with the command below:

sudo systemctl stop openhab

But it fails:

Failed to stop openhab.service: Unit openhab.service not loaded.

Any suggestions?

The logging in events.log changed I thing between the two versions. Updates are no longer shown at all. You will only see a changed to log event from a command if the command actually changes the state of the Item. You might see something like “Item new state is predicted to become X” inbetween.

I don’t have any advice for the second problem. As far as systemctl is concerned openHAB is not running. Did you start OH some other way than through systemctl?

I am using openhabian. After rebooting and trying systemctl start, got this:

Failed to start openhab.service: Unit openhab.service not found.

While the log files say everything goes all right (models loaded, states restored, devices online…)

Devices are connected to the mqtt broker, but cannot send or receive commands.
Would a downgrade help? (Is it possible at all?)

openHAB is configured to start automatically. And I’m pretty sure it’s openhab2 so the command should be

sudo systemctl start openhab2

You can also use openhab-cli start I think to start it running. But again, OH starts automatically anyway. You only need to start it if you happened to stop it at some point.

This is probably your original problem too. You need to stop openhab2.