RFXCOM 8.2 Binding - No Items Working

OH Version=1.8.2
RFXCOM Binding Version = 1.8.2
Installed and configured RFXCOM and from the RFXManager i am able to control shutters.

From the OH, doesn’t matter what item I configure, OH always reports subtype UNKNOWN. Even using the sample defined in Wiki https://github.com/openhab/openhab/wiki/RFXCOM-Binding

Items I have configured:
Rollershutter rsCurtain_BR "Curtains" { rfxcom=">1.1:BLINDS1.DC106:Shutter" } Switch ChristmasTreeLights { rfxcom=">636602.1:LIGHTING2.AC:Command" }

Screen Shots of the RFXManager for above Items:



Below are reported in the logfile:

`12:46:23.373 [DEBUG] [.rfxcom.internal.RFXComBinding:91 ] - Received command: rsCurtain_BR STOP
12:46:23.374 [DEBUG] [.rfxcom.internal.RFXComBinding:151 ] - Received command (item=‘rsCurtain_BR’, state=‘STOP’, class=‘class org.openhab.core.library.types.StopMoveType’)
12:46:23.374 [DEBUG] [.rfxcom.internal.RFXComBinding:195 ] - Transmitting data: 09190601000001110200
12:46:23.723 [DEBUG] [.b.r.internal.RFXComConnection:146 ] - Data received:
Raw data = 0402010100

  • Seq number = 1
  • Sub type = UNKNOWN
  • Response = ACK
    12:46:23.723 [DEBUG] [rfxcom.internal.ResultRegistry:49 ] - Transmitter response received:
    Raw data = 0402010100
  • Seq number = 1
  • Sub type = UNKNOWN
  • Response = ACK
    12:46:23.724 [DEBUG] [.rfxcom.internal.RFXComBinding:216 ] - Command succesfully transmitted, ‘ACK’ received
    12:46:24.810 [DEBUG] [.rfxcom.internal.RFXComBinding:91 ] - Received command: ChristmasTreeLights ON
    12:46:24.811 [DEBUG] [.rfxcom.internal.RFXComBinding:151 ] - Received command (item=‘ChristmasTreeLights’, state=‘ON’, class=‘class org.openhab.core.library.types.OnOffType’)
    12:46:24.811 [DEBUG] [.rfxcom.internal.RFXComBinding:195 ] - Transmitting data: 0B1100020009B6BA01010000
    12:46:25.384 [DEBUG] [.b.r.internal.RFXComConnection:146 ] - Data received:
    Raw data = 0402010200
  • Seq number = 2
  • Sub type = UNKNOWN
  • Response = ACK
    12:46:25.385 [DEBUG] [rfxcom.internal.ResultRegistry:49 ] - Transmitter response received:
    Raw data = 0402010200
  • Seq number = 2
  • Sub type = UNKNOWN
  • Response = ACK
    12:46:25.385 [DEBUG] [.rfxcom.internal.RFXComBinding:216 ] - Command succesfully transmitted, ‘ACK’ received`

I cant get any item defined and log file always - Sub type = UNKNOWN

Any help appreciated, thanks.

Can you please post the items from your items file, as well as any rules that you are using to send out the signals.

[edit: oops, just saw you have already put the items in]

Also, was everything working before 1.8.2 or is this the first attempt?

I have first tried in 1.8.1, which was my current version, but with rfxcom 1.8.2 addon - it had the same issue and then updated to OH 1.8.2. with the same result.
I have updated rfxcom firmware to latest firmware as well. I have tried various items as examples in the Wiki with the same result.

I have not rules defined yet.

Not sure if it makes a difference but I have the rfxtrx433E version.

It is my first attempt to get it going…

Ok, thanks.

I have the same device, though I have not updated to 1.8.2 yet.

I can tell you that when I send out signals form openHAB to the RFX unit, my log also gives me the “unknown” message. But like yours, it also gives the 2016-04-08 20:50:44.220 [DEBUG] [.rfxcom.internal.RFXComBinding] - Command successfully transmitted, 'ACK' received

I don’t know for sure, but I think the ACK response is an acknowledgment from the device, confirming that the transmission was received.

Ignoring openHAB for a second, when using RFXManager, are you able to turn the LIGHTING2 device on and off?

It looks like you are receiving the commands in openHAB but openHAB doesn’t know what to do with them.

Your item Switch ChristmasTreeLights { rfxcom=">636602.1:LIGHTING2.AC:Command" } is correct

The > in your item means that your are sending a signal OUT from openHAB to the RFXcom.

Which means the on and off command must come from a switch/rule in openHAB.

Try plopping the following in a browser replacing the IP with yours obviously. You can replace ON with OFF, you can also use TOGGLE and every time you hit refresh it should toggle.

See how you get on with that, try just the switch at the moment, becasue although I don’t have one, I know that rollershutters are more complicated to setup.

Good luck

Thanks for your feedback - it made me tackle the problem differently now knowing the log file states Subtype as UNKNOWN in a working setup as well.

I have the items defined in my sitemap as a switches.

The Switch ChristmasTreeLights { rfxcom=">636602.1:LIGHTING2.AC:Command" } was just used as an example of one of the items configured/defined in the Wiki to check if the Subtype is mentioned correctly…

I only have the Shutter now and since it was not working as described, my thought was that the output to the RFXCOM for not specifying the Sequence and Subtype correctly as it is shown as UNKNOWN.
I have taken the dirty way out, instead of transferring/calculating the values from the RFX Manager to an OH item, I have just defined the parameters in the OH and paired my receiver with the values send via OH.

I think the converting the data defined in the RFXCOM manager to the OH Items data/format might be wrong. I did what was explained in the Wiki and tried various configuration options.

Anyway, it is working now. thanks for your help.

Cool, glad it’s working.

Was there a specific reason for using the RFX Manager to send signals to openHAB? I think your “dirty way” is actually more like the right way :slight_smile:

I send everything to openHAB, and let openHAB send the signals to the devices. e.g. I have some Lightwave Dimmers that “out of the box” should be controlled directly via the supplied remote. I have openHAB detect the remote transmission, do whatever logic it needs and then sends out a signal to the Dimmers. I paired the Dimmers to the signal from openHAB and they behave as if they were controlled directly with the remote. Plus it means I can use the relatively cheap remote for anything in openHAB.

The same is true for wall switches in rooms, PIRs and thermometers. All sending out RF signals, with openHAB processing them.

But anyway, glad you have it working.

I was only using the RFX Manager to send signals to the RF/Shutter Control. I did this first when I got the RFX to make sure it was working :slight_smile: I bound/linked a configured RFX Blinds1 in RFX Manager to a Shutter and that was working. My next step was to transfer the already bound configuration from RFX Manager to an OH Item and that is were I got stuck. In future - I will follow the direct way and not use RFX Manager.