RFXCOM and Openhab 2 - Is it dead?

Hi. I have for a long time been trying to integrate rfxcom with openhab but it just doesnt work. Back a half a year ago it worked, kinda with oregon support but not lightning 4 (i need to send and receive commands). Ive been trying again but unfortunately no matter what i do (tried with official openhab 2.0 and the most recent snapshots) the binding will only discover my rfxtrx433E USB and when the thing is added it will say offline no matter what. It works perfectly with other programs like domoticz or rfxmgr. Is there anyone who can help me resolving my issue? I dont want the solution to be replacing openhab

Thanks in advance

I recently bought an rfxtrx433E USB and struggled to get it to work, it just wouldn’t show online. (I’m using ubuntu 16.04) I then found an earlier post that recommended attaching your rfxtrx433E to your windows PC via USB and set the required device modes manually (remember to save changes), reattach to openhab. Then in the PaperUI disable discovery of unknown devices. Worked for me and hasn’t failed since.

Sorry brain not working. I meant to say ‘skip transceiver configuration’ not ‘Disable discovery of unknown devices…’

I’m trying to turn “Disable discovery of unknown devices” ON as new devices keep getting added.

However, it doesn’t seem to matter what combination of other configuration settings are set, when I set ‘Disable discovery of unknown devices’ to ON, I get a Error 409: conflict message and the RFXCOM USB Transceiver thing is not updated.

I;m running openHAB 2.2.0~20171030010135-1 (Build #1072) on a RPi.

Any ideas?

Thanks

There were a lot of changes to the RFXCOM binding over the summer. A fix for setting device modes was committed at the end of May so the early part of this thread is stale.

Flipping the “disable discovery” switch just toggles a boolean in the binding code. The 409 seems to be something between the UI and the binding. Did you add your transceiver thing some time in the past prior to an upgrade or too? If so it might be that you need to delete it and re-add it?

Thanks for the reply. I added the RFXtrx433E earlier in the year but upgraded the binding recently.

I’ll try deleting and re-adding the transceiver thing.

I can’t delete the RFXCOM transceiver bridge using PaperUI - I get

ERROR: 409 - CONFLICT

I can see the thing in things list in Karaf console but I cannot remove it (assuming I am going around it in the right way:

things remove rfxcom:bridge:usb0

I can’t even see the thing in the org.eclipse.smarthome.core.thing.Thing.json file.

Any suggestions for deleting it?

If you stop openHAB it has to be in either the json file or under conf/things/.

1 Like

Of course you were right. It was in conf/things/ but when I opened the file, I didn’t scroll up to the top of the file (not sure why I had to do that) and it was actually on the top line.

Anyway, it seems to work now and auto-discovery is now disabled and stays that way.

Thanks for your help.