Rfxcom on synology

I’m trying to use a rfxcom usb device on a synology with OpenHAB. However, I am getting the following error:

  2015-10-03 16:49:50.734 [INFO ] [.b.r.internal.RFXComConnection] - Connecting to RFXCOM [serialPort='/dev/ttyUSB0' ].
    2015-10-03 16:49:51.666 [ERROR] [.b.r.internal.RFXComConnection] - Connection to RFXCOM controller failed.
at org.openhab.binding.rfxcom.internal.connector.RFXComSerialConnector.connect(RFXComSerialConnector.java:60) ~[na:na]

at org.openhab.binding.rfxcom.internal.RFXComConnection.connect(RFXComConnection.java:118) ~[na:na]
at org.openhab.binding.rfxcom.internal.RFXComConnection.updated(RFXComConnection.java:103) ~[na:na]

However, if I run Domoticz on the same synology, I am able to use the rfxcom device without problem on the same serial port (/dev/ttyUSB0).

Here’s my openhab.cfg section:


Any help would be greatly appreciated.

PS: this is the corresponding dmesg entry:

usb 1-1.2: FTDI USB Serial Device converter now attached to ttyUSB0

ttyUSB0 was locked in /var/lock, just removed it and the binding started working.

Actually, I’m still struggling with this issue. I was running OpenHAB as root while testing this issue and the connection to the serial port worked fine. However, when running under the openhab user the connection fails. I’ve tried to change the rights to /dev/ttyUSB0 to no avail.