RFXCOM & Somfy RTS Blinds

Hi all,

I have managed to set-up a new Somfy Wirefree RTS roller blind motor with OpenHab using the RFXCOM binding but i can only get the blind to move up and down momentarily. Does anyone know of a trick to get the blind to run up and down to its sent limits? I think i need to make use of the UP_2SEC command but unsure.

Any advice of help would be great!

Running openhabian 2.0.0 on Raspberry Pi 3 with a USB RFXtrx433E.

Thanks Again!


I set the limits of my Somfy RTS motor with the remote, i dont know if that is wat you mean?

See movie with instructions https://www.youtube.com/watch?v=9jmaGn1vs1I

Maybe you can also do it programmatically with openhab, so dat openhab replaces you remote

Hi Michael,

I had already set the limits but you made something click for me, i still had the blind in program mode! I did not buy a remote with my blind so i had to setup the limits using the RFXCOM manager utility. The last step in setting the limits is to put the blind in “user mode”, the button on the back of the remote. In the utility this is the “program” command.

Now the blind goes fully up and down with openhab. Thanks for your help.


I’m trying to setup my venetian blinds but cannot get them work with OH2. They work fine with the Somfy remote and with my OH1 setup. Most probably I’ve setup the wrong thing or item… Could you point me in the right direction?

Best regards,