Ring Binding [3.2.0;4.0.0)

Thx for your quick reply. I will send you the logs next days. have a nice weekend.

1 Like

It looks like this may have been on Rings end. My system had several spikes and then went completely calm. Is anyone still seeing the dips to 0?

Everything seems to working now. You are the best :slight_smile:
I’m now getting the ring videos via telegram and also the battery item are working fine.

Here is my rule for sending the video via telegram which is working fine for me …

rule “Ring Bridge URLvideo Test”
when
Item Ring_Bridge_URLvideo changed
then
val telegramAction1 = getActions(“telegram”,“telegram:telegramBot:Bot_Christian”)
var String RingURLtoText = “/openhab/userdata/ringvideo/” + Ring_Bridge_URLvideo.state.toString.substring(34)
telegramAction1.sendTelegramVideo(RingURLtoText, “RING: Video”)
end

I’m closing out the battery weirdness as a problem on the Ring side. Mine has been stable for days now.

Awesome! Glad to hear things have sorted out.

To anyone else on this thread, are there any open/outstanding issues/defects?

As far as feature requests, I’m tracking the intercom to be added but that’s it. Are there any other devices they make that should be added? I’m not looking at the alarm right now, there is a whole other level of crazy involved there. Alarm is on the list, but it will be after the code is reviewed/merged and I have some time to think about it (plus I don’t actually own one so testing is going to be complicated).

1 Like

I just pushed a new version to the main post (2a0dbc6). This fixes some issues the binding was having with the chimes (they should show up now) and also adds the “other” type. Other is actually what Ring calls them so I’m keeping the nomenclature. This should include devices like the intercom.

EDIT: One follow-on note. I am seeing conversations across some of the other Ring API communities that there have been issues with the API for about 2 weeks now. For the moment I haven’t seen an impact to us (minus maybe that battery issue). It does appear that Ring is moving from a poling model to a push model for events so we may see (with obviously no notification at all) events just stop working one day. I’m going to try to preempt this by seeing if I can add push notification support at some time in the near future. I need to look at how to do this more carefully so we don’t end up getting both a push and a pull of the same event. If anyone notices their events just suddenly stop please let me know so I can go see if it happened. Thanks!

1 Like

Mine showed up.

Thanks, Jay

@morph166955 Thanks for this - I was using MQTT Broker before but this is much easier…

Some slight odd behaviour I’m seeing. I have both a Doorbell and Stick-Up Cam on my Ring Account. Both are detected fine, and both send events. This is all good. I have my Stick-Up Cam setup in Ring as a Linked Event, so that when my Doorbell rings, the Stick-Up Cam also starts recording the event.

However, I’m not sure if this is somehow causing a conflict in the Binding. My Event timestamp updates correctly, but after the Event changes to “ding” from the Doorbell being rung, every several seconds the Event alternates from “ding” to “on_demand_link” and back again - without the Event timestamp changing. It looks like the OpenHAB Item for the Event is alternating between the two without a new Event timestamp?

Here’s a screenshot of my Logs:

Can you please put the binding into trace (this will get verbose), trigger an event, and send me the whole thing in a text file via DM? I’ll need to see what they are sending us before I’ll be able to see why that’s happening.

1 Like

Do I miss something?? I just added the ring-binding from the market-place and tried to add my account, but there ist no possibility to add the account-thing. The docu said “use the paper-UI”, but I use OH4, and do not have the paper-UI…

If I use the textual-config (which is not recommended if one use 2FA, what I do), I get the account-thing, but cannot edit it to use 2FA, because its locked.

any hint would be great!

Good point with the paper UI. On OH4 that would just be the main UI. When you go into things on the main UI, hit the plus, and hit Ring it’s just blank? What OH4 version are you on? I’m running a snapshot that’s maybe a week old and it’s been ok.

I just upgraded my test device to openHAB 4.0 SNAPSHOT. Using the Ring binding from the marketplace, I’m seeing this in the log:

2023-05-29 08:07:30.670 [ERROR] [hab.binding.ring.internal.RestClient] - RingVideo: Unable to create folder /etc/openhab2/html/ring/video, cannot download.: /etc/openhab2

My suspicion is that my production device has a bunch of openHAB 2 remnants, so it had that folder. But my shiny new, clean openhabian / openHAB 4 does not have that folder.

That’s odd. Ill try to grab some screen shots later today on my dev box to compare against. You should see an option to manually add the account thing. Have you restarted openhab? Maybe clear cache?

Thanks. I have restarted openHAB and stopped, cleared the cache, and restarted. I was using the .jar file provided above in openHAB 3.4.4. When I upgraded to openHAB 4.0 SNAPSHOT, I deleted that .jar file from the addons folder and then installed the Ring binding from the Marketplace. Anything I can do to help troubleshoot, please let me know.

Just to make sure I’m understanding, it worked on 3.4.4 but fails on 4.0?

I filed a bug on this. For some reason, marketplace added bindings aren’t showing manual things to add.