Ring doorbell

Tags: #<Tag:0x00007faed9db4f90>

Ring doorbell would be exactly what i want to have, but only in hardware way. I want to do the software part with my own server-storage and openhab cloud.

So long there is no alternate firmware or a way to send the ring data directly to my server instead of ring-cloud, i will have to search for another device.

Actually, I also have a ring (though I have a doorbird as my main doorbell) and if there would be an alternate firmware or other direct storage way, I’d use this, too!

I am praying someone creates a binding for Axis doorbell (eg A8105)

I have a Ring. I saw that someone has created a add-on to Home Assistant for Ring. I saw it’s advertisement on their add-on page. I checked it out on You-tube and it looks great. I wonder if the code is on Git.

Hi All,

Finally got around to installing this binding, but I am having the same issues that people have mentioned before, I am getting the “401 Unauthorized” error when attempting to download the latest video from the ring server. Getting the recording link from the Rest API, I can open it in a browser window, but to execute a wget to download, I get the 401.

I have tried downloading the most recent video, was timestamped yesterday, so there should be no issue with the ring server rendering it. Also, everything else seems to be working. I have also cut and pasted some of the rules from this post (changing the item names only to match my system) and I nothing is downloaded. Is there any special permissions that need to be set? I am using OpenHabian 2.4.0.0.1 (stable release).

Thanks for the binding, seems to work well so far!

~John

what’s the wget command you are using?
you need to specify the token

@markus7017,

I copied my “RingURL” from the Rest API, going to items and getting the state, copying it to a new tab to make sure the link works, which has the token in the link. So, I’ve been using:

wget https://api.ring.com/clients_api/dings/XXXXXXXXXXXXXXXXXX/recording?api_version=11&auth_token=[xxxxxxxxxxxxxxxxx] -O /etc/openhab2/tmp/ring.mp4

The last event was from about 5 minutes ago, so the ring servers should have had plenty of time to render or save the video.

~John

Hi, I’ve got a Ring Pro with a chime installed, I use this binding with latest snapshot OH2, but I experience, when OH starts, the things and items coming online, but after a while, the battery status stops refreshing. It seems it’s just getting on startup, but there is no any update, when it’s changing in the ring app. Is there any way to query this information? Last year, when I bought the Ring Pro, the first one worked only 20 days. The Li-Po battery inside exhausted, and the whole Ring Pro died. The support sent to me a new one, it worked only for 15 minutes on my desk… The support sent to me a 3rd one, this is what works since last december. This is why it’s really important for me :).

Are you still getting other events like motion and ring?

Unfortunately not. When OH starts, the account and the device things going online, after that may the first action noticed the items, but later nothing. The things are online, I can restart the bundle or disable and re-enable the thing on paper ui, the things go to down and back to up online, but there is no updates. All of my other stuff works like a charm, I’ve got notices via IFTTT from Ring, and my google home mini speaks when an action happens.First time I’ve used the paper ui for the configuration, but I’ve wrote it into files later. It seems it isn’t helped.

Update:
Today morning I’ve experienced, the ring account was in offline (comm error) state. I’ve disabled the account thing and re-enabled it:

2019-06-29 10:11:23.167 [hingStatusInfoChangedEvent] - 'ring:account:ringAccount' changed from OFFLINE (COMMUNICATION_ERROR): Initialization failed: null to UNINITIALIZED
2019-06-29 10:11:23.242 [hingStatusInfoChangedEvent] - 'ring:account:ringAccount' changed from UNINITIALIZED to UNINITIALIZED (DISABLED)
2019-06-29 10:11:24.165 [hingStatusInfoChangedEvent] - 'ring:account:ringAccount' changed from UNINITIALIZED (DISABLED) to INITIALIZING
2019-06-29 10:11:24.196 [INFO ] [hab.binding.ring.internal.RestClient] - Creating Ring client for API version 11 on endPoint https://api.ring.com
2019-06-29 10:11:25.821 [hingStatusInfoChangedEvent] - 'ring:account:ringAccount' changed from INITIALIZING to OFFLINE (CONFIGURATION_PENDING): Retrieving device list
2019-06-29 10:11:26.500 [hingStatusInfoChangedEvent] - 'ring:account:ringAccount' changed from OFFLINE (CONFIGURATION_PENDING): Retrieving device list to ONLINE
2019-06-29 10:11:26.936 [hingStatusInfoChangedEvent] - 'ring:doorbell:xxxxxxxx' changed from OFFLINE (CONFIGURATION_PENDING): Waiting for RingAccount to initialize to ONLINE
2019-06-29 10:11:26.943 [vent.ItemStateChangedEvent] - RingBatteryLevel changed from 3983 to 4001
2019-06-29 10:11:31.439 [vent.ItemStateChangedEvent] - RingEventVideoURL changed from https://api.ring.com/clients_api/dings/xxx/recording?api_version=11&auth_token=xxx to https://api.ring.com/clients_api/dings/xxx/recording?api_version=11&auth_token=xxx

The battery state updated.

Update #2
I’ve set DEBUG log level for Ring binding, and captured the REST responses from the site, it’s strange, my app shows the battery level changed from 4001 to 4000, I’ve killed the app on my phone, started again, it’s 4000 yet. After that I’ve restarted the account thing on paper ui, there wasn’t any update for battery level item, because the REST response contains 4001 yet instead of 4000, what my app shows.

"time_zone":"Europe/Budapest"
"subscribed":true
"subscribed_motions":false
"battery_life":4001
"external_connection":false
"firmware_version":"Up to Date"

As far as I said, this device is the third one, what I use, may it confused my device inventory on ring’s site. I’ve deleted all of the devices what I’ve sent back when the last one arrived and started working well. I’m a bit confused, it seems the binding doing well, but false data arrives from the api.

May I have to open a ticket on Ring support…

could you explain this a little? (changing the video size in the sitemap)

That is strange, but it would explain why it’s not updating in the binding and possibly some of the other strange issues others have experienced. I don’t know if Ring will be particularly helpful since the api isn’t public but it might be worth a shot reaching out.

I’ve tried, the first line support was very kind, but when he asked the advanced support with regards of my case, they closed the door, because it’s not an official ring partner’s product :slight_smile:.

I’m also noticing a 30 second delay from when motion activated, until say the light turns on. My rule is below:

rule "Turn gOutsideFrontDoorLights On When Ring_Account_EventKind is motion activated at Night then turn off automatically after 60 seconds"
when
	Item Ring_Account_EventKind received update
then
	if (NightMode.state == ON && Ring_Account_EventKind.state == "motion")
	{
	sendCommand(Brightness_Outside_FrontDoor_Light, 100)
	
	createTimer(now.plusSeconds(60)) 
	[|
		if (Toggle_Outside_FrontDoor_Light.state == ON) {
			sendCommand(Toggle_Outside_FrontDoor_Light, OFF)
			}
    ]
	
	}
end

Anybody else experiencing a 30 second delay before it notices the motion from the Ring Doorbell?

Is the binding available on the Github page listed above? I did try to pick up the feed using the Windows Ring App and tried to screencast it but didn’t have any luck. If you can get the screencast packet information you should be able to get the live video into any video security app via Windows or Android.

@sonyxperiageek Unfortunately the “API” seems to be very slow on their side lately, I don’t know if there’s anything that can be done.

@Teknokill i’m not sure which github link you’re referring to but the latest that i’m aware of is mine at https://github.com/zolakk/openhab2-addons-ring/ . It seems that there’s a 10-30 second delay from the event (motion, ring) before there’s a valid link to the video file. I don’t know of any way to get live view going though.

At the moment to compensate, I am using an IFTTT applet to trigger the Hue light when it detects motion during night time. This works almost instantaneous. Would their rule not be using the API too?

Is there a way to send the ring video to telegram so its automated played when an notification even whit a 30 sec. delay doesen`t matter becurse if i am home i will get a message from the chime

One problem is that the binding pools for the status, it‘s not event driven. So maybe the IFTTT integration gets an event and could react instantly. However I also notice that the Ring App from time to time shows these delays