Ring doorbell

Anyone updated to 4.8.3 and still get the errors?

Just updated, warning messages are still there.

I updated as well. Same errors. I opened an issue on GitHub. Due to this discussion I found a fix for now. In short, create your own MQTT-Things and configure the channels and do not use the auto discovered mqtt:homeassistant-based Thing.

@arjan-io, would you mind sharing a sample configuration for a Ring device or two?

If you haven’t removed the mqtt:homeassistant stuff yet, find the location ID, device IDs and the type from their respective MQTT-topics.

Now make sure you (have) install(ed) the MQTT binding.

Under Things, click the + and click on ‘MQTT Broker’ to set up the Bridge.

Under Things, click the + and click on ‘Generic MQTT Thing’.

Give it an ID, Label and point to the MQTT Bridge you just created.

Go to the tab ‘Channel’ and click on ‘Add Channel’.

Give it an ID, Label, click on the Type it should represent and then in the State topic box use the lay-out given on the RING-MQTT GitHub page. So ring/<location_id>/<ring_category>/<device_id>/<device_type>/state .
For example mine looks like ring/a798baXX-XXXX-XXXX-XXXX-XXXXXXXc22a9/chime/54eXXXXXXd3b/snooze_minutes/command.

Link your Channel to your Item and you should be set. Good luck!

I think there is an update about to be released (version 4.8.4) in which is should be fixed. I tested it today and personally have no further log errors.

Yes, I do. For the time being I chose to filter them out. Especially those JINJA messages are a pain …

I’ve got a Ring Doorbell. How does I get a live stream?
MQTT is already configured and online. But how I get the camera working?

Thanks!

This is an un-official Ring 3.x release and there is NO maintainer for this version, Siriram did me a BIG favor doing this for me. I’m still testing it but it does come up for account and doorbell THING.

Best, Jay

Hi,

I’m also getting these warning logs after adding ring(mqtt) items/things and could not figure out a way to resolve it. I’ve checked MAP transformation files and still no luck.

My ring-mqtt installation suddenly went completely quiet - I can see it properly connecting to Ring, but no messages are being published to mqtt and no errors, nothing. Has anybody seen anything similar?
ring-mqtt developer has gone underground, so I am a bit at a loss here.
I am running ring-mqtt in docker if it makes a difference.

Ring’s stance on their API since 2015 has been “Coming soon”, it’s existed but pretty much only been in the background, everything that currently exists has been reverse engineered. About 2 months ago Ring changed their stance from “Coming soon” to “We do not support ANY api for non-Ring partners” they also scrubbed their forums of the little API access they did trickle out. My guess is they are most likely killing more and more of what remains and reverse engineered integrations are just going to die. I have already replaced half my ring devices with Ubiquity for this reason.

Back alive after restart and token refresh. Looks like it was impacted by yesterday AWS outage.

Worked for me. Thank you very much!

How did you filter that out?

All, May I please ask a quiestion on the path setting. I want to dump the videos in a windows folder. I’ve allowed full access to the windows folder but not getting the dumps?

\HOME-SERVER\Users\daniel\Documents\Ring\Video.

Not sure if it should be a single \ for double \.

Thanks

Regards

Is somebody able to get a livestream from Ring Doorbell on demand? If yes, how do you do that?

I would love to know as well :slight_smile:

Angelo:

Hello guys,

I also bought a Ring and now want to add it to openhab using this mqtt ring docker image.

I am trying to install but struggeling with the mount path configuration (it´s not described in the official documentation?!).

Using Synology NAS Docker app to use this docker image.

Can someone help me out? Thanks !

EDIT:

Okay I solved it on my own. I used the CLI commands as described in the documentation instead of the GUI from Synology NAS. My mounting path was “/volume2/docker/ring” if anybody wants to know.