Rollershutter openhab2?

help please

  • Platform information:
    • Hardware: _PI 3
    • openHAB2

I have Electric shutter I connected two Relay 1 operation UP and one operation DOWN
I do not know how to open the shutter to 50%, and how to shutter button hours

MY Items

Switch Win_on1 “Win_on1” (gLight3) [ “Lighting” ] {mqtt=">[broker:cmnd/windows/POWER2:command:*:default], <[broker:stat/windows/POWER2:state:default]", autoupdate=“false”}

Switch Win_off “Win_off” (gLight4) [ “Lighting” ] {mqtt=">[broker:cmnd/windows/POWER1:command:*:default], <[broker:stat/windows/POWER1:state:default]", autoupdate=“false”}


Frame label=“Win_on1”
Switch item=Win_on1
Frame label=“Win_off”
Switch item=Win_off

MY Rules

rule “win on 13s”

 Item Win_on1 changed to ON


 createTimer(now.plusSeconds(13),  [ |



rule “win off 14s”


 Item Win_off changed to ON


 createTimer(now.plusSeconds(14),  [ |



Thank you

Does your shutter output the value, via mqtt, as a percentage?

Your rule will only make the shutter move for the specified time. Need to post all of the mqtt message to see what is needed to work with using timer.

You are using tasmota, which has now a rollershutter option

Yes, thank you

Please click the post with solution.

Thank you
Is that what you mean?

2019-12-27 15:51:41.231 [vent.ItemStateChangedEvent] - Win_on1 changed from ON to OFF

2019-12-27 15:51:43.053 [ome.event.ItemCommandEvent] - Item ‘Win_off’ received command ON

2019-12-27 15:51:43.224 [vent.ItemStateChangedEvent] - Win_off changed from OFF to ON

==> /var/log/openhab2/openhab.log <==

2019-12-27 15:51:43.228 [WARN ] [eneric.internal.generic.ChannelState] - Command ‘ON’ not supported by type ‘RollershutterValue’: null

==> /var/log/openhab2/events.log <==

2019-12-27 15:51:43.257 [ome.event.ItemCommandEvent] - Item ‘Win_off’ received command ON

==> /var/log/openhab2/openhab.log <==

2019-12-27 15:51:43.323 [WARN ] [eneric.internal.generic.ChannelState] - Command ‘ON’ not supported by type ‘RollershutterValue’: null

==> /var/log/openhab2/events.log <==

2019-12-27 15:51:46.157 [ome.event.ItemCommandEvent] - Item ‘Win_off’ received command OFF

==> /var/log/openhab2/openhab.log <==

2019-12-27 15:51:46.223 [WARN ] [eneric.internal.generic.ChannelState] - Command ‘OFF’ not supported by type ‘RollershutterValue’: null

==> /var/log/openhab2/events.log <==

2019-12-27 15:51:46.233 [vent.ItemStateChangedEvent] - Win_off changed from ON to OFF

2019-12-27 15:51:51.613 [ome.event.ItemCommandEvent] - Item ‘Win_on1’ received command OFF

==> /var/log/openhab2/openhab.log <==

2019-12-27 15:51:51.646 [WARN ] [eneric.internal.generic.ChannelState] - Command ‘OFF’ not supported by type ‘RollershutterValue’: null

==> /var/log/openhab2/events.log <==

2019-12-27 15:51:57.263 [ome.event.ItemCommandEvent] - Item ‘Win_off’ received command OFF

==> /var/log/openhab2/openhab.log <==

2019-12-27 15:51:57.311 [WARN ] [eneric.internal.generic.ChannelState] - Command ‘OFF’ not supported by type ‘RollershutterValue’: null

14:48:50 MQT: stat/windows/POWER1 = ON
14:48:53 MQT: stat/windows/RESULT = {“POWER1”:“OFF”}
14:48:53 MQT: stat/windows/POWER1 = OFF
14:48:57 MQT: stat/windows/RESULT = {“POWER1”:“OFF”}
14:48:57 MQT: stat/windows/POWER1 = OFF
14:48:59 MQT: stat/windows/RESULT = {“POWER2”:“OFF”}
14:48:59 MQT: stat/windows/POWER2 = OFF
14:49:04 MQT: stat/windows/RESULT = {“POWER1”:“OFF”}
14:49:04 MQT: stat/windows/POWER1 = OFF

Take a look here for the roller shutter commands.

You will likely need to use a transformation with the mqtt version 1.x. Have you considered upgrading to mqtt version 2.x ?

I am new in OPENHAB

How do I upgrade to mqtt 2.x version?

Thank you

Did you install OH via the openhabain image?

If so, then from the command line type sudo openhabain-config to open the config tool. Pick the first option, then second and then the third.
See this link:

Also before upgrading go to PaperUI and uninstall RestUI. This will save you a bit of time.:wink:

You need to make a backup first. From command line type sudo openhab-cli backup --full it will make a zip file and give the location. You will need to move this zip file to your PC (I use fileZilla) or onto a USB stick or where ever just move it off the OH server.

Thanks I will try

Hi H102

I did a backup, and an update to the system
What now ?

Thank you

Check the logs and make sure there is not issues with OH. If all is good install the mqtt binding from PaperUI > Addons > Bindings then configure your mqtt Thing and generic mqtt things for the devices.

mqtt is installed
what is the next step ?

Thank you



Read what?

MQTT link above and Tasmota rollershutters

Thank you
But how do I write it in Items, Sitemaps, Rules ?

Have a go
When it doesn’t work come back here and post what you did
We are not going to do it for you. You won’t learn anything

You try. You make mistakes. You swear a bit. You get fustrated. You try again.
You have a coffee. You read again. You try again. You search the forum (Hint: the answer is in there already)
You try again. When you are really stuck. come back here. Post what you did and we’ll help.

Hint, hint: [SOLVED] MQTT v2 Binding with Tasmota Sonoff T1 rollershutter

I ask for help here after trying a few ways and I did not succeed
It is true that the easiest way is to get help, but trust me I have tried a long time before I came here