Rollershutter shows random position OH 2.4


(Arjan) #1

Hi,

I have upgraded to OH2.4. After the upgrade everything was acting weird so I just deleted OH and installed a complete fresh 2.4 and added all bindings again.

I have 2 rollershutters connected via Z-wave. In both the basicUI and app on my iPhone, if I press the ‘down’ or ‘up’ button, the icon and percentage values change to the position the shutter has after more or less 1,5 secs of operation. Ie. when it was open, and I press DOWN, after 1,5 secs the UI/app updates to the position at that time. (around 5% closed). The shutter goes down towards 100% closed but the state does not receive the update of its final position. Same goes for UP.

Does anyone else has (had) this problem? Is this an error or configuration issue? Any advice is appreciated!

Best regards


(Christian Hojas) #2

I am stuck in exactly the same problem. Several reboots and synchronisations of the rollershutters did not deliver any solution.


(Sebastian Sp.) #3

Hey all together,
I am new to this Forum. Had a working configuration on OH 2.2.

I decided to make a new clean OH 2.4 Setup. I see the same behavior as arjan-io and jackSparrow. I guess the config is correct, i can adress the shutters with all controls. Also sendCommand with percentage works. Only the percentage values show random values.

Can anyone Help here?

BR


(Rossko57) #4

Please show us events.log for the duration of a move


(Christian Hojas) #5

Wohnung_Kueche_ROS was at 100% before the action started. This could have been only reached by manually closing the shutter again after closing. Otherwise it would have been somewhere between 95 and 98 %.

2019-01-11 08:11:00.118 [ome.event.ItemCommandEvent] - Item 'Wohnung_Kueche_ROS' received command UP
2019-01-11 08:11:00.137 [nt.ItemStatePredictedEvent] - Wohnung_Kueche_ROS predicted to become UP
2019-01-11 08:11:00.154 [ome.event.ItemCommandEvent] - Item 'Wohnung_Wohnzimmer_ROS' received command UP
2019-01-11 08:11:00.162 [vent.ItemStateChangedEvent] - Wohnung_Kueche_ROS changed from 100 to 0
2019-01-11 08:11:01.996 [vent.ItemStateChangedEvent] - Wohnung_Kueche_ROS changed from 0 to 98

After the controller received the command “UP” it opens the shutter completely. But meanwhile, the status value changes to 98% (that is truelly after the shutter begins to open, so at this time this value seems to be correct). But the status never changes to 0% when the shutter is completely opened.


(Sebastian Sp.) #6

Hey,
here is my result. I have a switch button that sets the roller shutter to 50%. All i working except the blind control shows a random number. initially the shutter was @ 0%. in this case it is set to 19%.

Blockquote
2019-01-11 12:02:43.647 [ome.event.ItemCommandEvent] - Item ‘ButtonRoller’ received command 88

2019-01-11 12:02:43.661 [vent.ItemStateChangedEvent] - ButtonRoller changed from 1 to 88

2019-01-11 12:02:43.698 [ome.event.ItemCommandEvent] - Item ‘RSWohnzimmerFenster_BlindsControl’ received command 50

2019-01-11 12:02:43.708 [nt.ItemStatePredictedEvent] - RSWohnzimmerFenster_BlindsControl predicted to become 50

2019-01-11 12:02:43.728 [vent.ItemStateChangedEvent] - RSWohnzimmerFenster_BlindsControl changed from 6 to 50

2019-01-11 12:02:43.741 [vent.ItemStateChangedEvent] - RSWohnzimmerFenster_BlindsShutter changed from 13 to 50

2019-01-11 12:02:43.748 [vent.ItemStateChangedEvent] - ZWaveSerialController_SerialAck changed from 159 to 160

2019-01-11 12:02:43.752 [vent.ItemStateChangedEvent] - ZWaveSerialController_SerialSof changed from 397 to 398

2019-01-11 12:02:43.765 [vent.ItemStateChangedEvent] - ZWaveSerialController_SerialSof changed from 398 to 399

2019-01-11 12:02:45.259 [vent.ItemStateChangedEvent] - ZWaveSerialController_SerialAck changed from 160 to 161

2019-01-11 12:02:45.266 [vent.ItemStateChangedEvent] - ZWaveSerialController_SerialSof changed from 399 to 400

2019-01-11 12:02:45.315 [vent.ItemStateChangedEvent] - ZWaveSerialController_SerialSof changed from 400 to 401

2019-01-11 12:02:45.346 [vent.ItemStateChangedEvent] - ZWaveSerialController_SerialSof changed from 401 to 402

2019-01-11 12:02:45.398 [vent.ItemStateChangedEvent] - RSWohnzimmerFenster_BlindsControl changed from 50 to 19

2019-01-11 12:02:45.402 [vent.ItemStateChangedEvent] - ZWaveSerialController_SerialAck changed from 161 to 162

2019-01-11 12:02:45.406 [vent.ItemStateChangedEvent] - ZWaveSerialController_SerialSof changed from 402 to 403

2019-01-11 12:02:45.445 [vent.ItemStateChangedEvent] - ZWaveSerialController_SerialSof changed from 403 to 404

Blockquote

Thanks


(Arjan) #7

They indeed did not.

Neither was clearing the cache and tmp folders successful with me.

-trying to get the log file out now-


(Arjan) #8

I have custom logsettings so I did not get anymore then:

2019-01-11 14:06:32.169 [smarthome.event.ItemCommandEvent                  ] - Item 'rolluikZolderRechts' received command DOWN
2019-01-11 14:06:32.179 [smarthome.event.ItemStatePredictedEvent           ] - rolluikZolderRechts predicted to become DOWN
2019-01-11 14:10:58.076 [smarthome.event.ItemCommandEvent                  ] - Item 'rolluikZolderRechts' received command UP
2019-01-11 14:10:58.081 [smarthome.event.ItemStatePredictedEvent           ] - rolluikZolderRechts predicted to become UP
2019-01-11 14:11:02.862 [smarthome.event.ItemCommandEvent                  ] - Item 'rolluikZolderRechts' received command UP
2019-01-11 14:11:02.882 [smarthome.event.ItemStatePredictedEvent           ] - rolluikZolderRechts predicted to become UP
2019-01-11 14:11:08.570 [smarthome.event.ItemCommandEvent                  ] - Item 'rolluikZolderRechts' received command UP
2019-01-11 14:11:08.593 [smarthome.event.ItemStatePredictedEvent           ] - rolluikZolderRechts predicted to become UP
2019-01-11 14:11:12.763 [smarthome.event.ItemCommandEvent                  ] - Item 'rolluikZolderRechts' received command UP
2019-01-11 14:11:12.770 [smarthome.event.ItemStatePredictedEvent           ] - rolluikZolderRechts predicted to become UP
2019-01-11 14:11:20.238 [smarthome.event.ItemCommandEvent                  ] - Item 'rolluikZolderRechts' received command UP
2019-01-11 14:11:20.247 [smarthome.event.ItemStatePredictedEvent           ] - rolluikZolderRechts predicted to become UP

The last up, up and up-commands are done to see what happened if the shutter was moving. Well, each time I pressed the up botton, the current position of the screen would show on the UI.

I tried log:tail in karaf but the same rules apply to that log as to the events one I guess as they are no different. Even with debug on the wave binding…


(Sebastian Sp.) #9

Hi,
found a solution that worked for me. was in another thread.

https://community.openhab.org/t/solved-rollershutters-position-percentage-not-updating/56377/13

For me it solved the issue.

BR,
Sebastian


(Andrej Rolih) #10

I had the exact same issue. What did it for me was simply selecting “Reinitialise the device” in the thing settings. After that everything started working normally again.


(Arjan) #11

That did it for me too. Thanks!


(G) #12

having the same problem after updating to 2.4
after sending a command for example from 0 to 100 the slider shows random intermediate value while the shutters are moving. this did not happen on 2.3 it looks very ugly on the wall tab as well as confusing. The predicted value should be shown instead while the shutters are moving.
EDIT: ok for anyone having the same issue, in 2.4 there is a new setting called: command poll period. the default is 1500 (1.5 seconds) just select “disable” and it will stop the intermediate updates on roller shutters. The shutter will send an update on its position once it has stopped moving, so this setting is not needed for roller shutters