Rollershutters KNX: Position read + Position move [SOLVED]

Hello!
From the doc at: https://github.com/openhab/openhab/wiki/KNX-Binding
the syntax for KNX Rollershutters is:

/* Rollershutters Up/Down, Stop/Move */
Rollershutter Shutter_GF_Living "Shutter" (GF_Living, Shutters) { knx="4/2/10, 4/2/11" }

/* Rollershutters  Up/Down, Stop/Move, Position */
Rollershutter Shutter_GF_Living "Shutter" (GF_Living, Shutters) { knx="4/2/10, 4/2/11, 4/2/12" }

but I have 4 groups:

  1. Up/Down
  2. Stop/Move
  3. Position (Position read)
  4. Position (Position move/go-to)

For use OpenHAB I need to put KNX Position “Read” together with Position "Move Go-To"
In this case there are some issues.

For example :

  • using a “move up” or a “sendCommand(Rollershutters, 0)” openHAB show shutter completely opened even if it’s locked (for example by meteo alarm)

  • during a manual stop (with a button in the home) the KNX actuator sends commands read to move-to creating a jump/fine moving every time after the stop (this is not healthy for the shutters motors)

Is it possible to use/change the syntax as this?

/*Rollershutters**  **Up/Down, Stop/Move, Position read, Position move*/
Rollershutter Shutter_GF_Living "Shutter" (GF_Living, Shutters) { knx="4/2/10, 4/2/11, 4/2/12, 4/2/13" }

Best regards

Sim

For the 1. issue (report an opened rollershutter because of an up command) please use autoupdate=“false”:

Rollershutter Shutter_GF_Living "Shutter" (GF_Living, Shutters) { knx="4/2/10, 4/2/11, 4/2/12", autoupdate="false" }

the effect is, the item will only be updated from commands or states from knx bus, but not from commands initiated by openHAB itself (UI or rules) Of course you still can update the state with <item>.postUpdate(state).

For the 2nd issue (Step after manual stop) I did not notice such behavior, so please show the complete definition (including rules) regarding your rollershutter.

Configuration with absolute position should be like

Rollershutter Shutter_GF_Living "Shutter" (GF_Living, Shutters) { knx="4/2/10, 4/2/11, 4/2/12+<4/2/13", autoupdate="false" }

where 4/2/13 would be the position read and 4/2/12 would be the position set GA, so openHAB would read the state at startup from 4/2/13 and would change the item state if receiving any messages at 4/2/13 or 4/2/12 but would never send a command to 4/2/13

2 Likes

Hello Udo!
Wowww… real accurate description! Thanks!

I did not know the option autoupdate=“false”.
This behavior is not present in other KNX Items, right?

Example:
Switch Lamp "Lamp" (Lights) { knx = "<1/0/10" }

The lamp is updated only if the real states change from knx bus and not after the “openHAB click”


For the 2nd issue (Step after manual stop) I did not notice such behavior

With my ABB JRA/S if I put KNX Position “Read” together with Position “Move Go-To”, after the manual stop the JRA/S send “position” but probably rounding decimals.

Example:
State 0% -> Move -> Stop -> Real position is 50,4% -> JRA/S send position 50% -> the shutther jumps back to 50%

I will follow your instructions tonight

Thanks again!

Sim

Solved!

The solution is perfect! Thanks again

Sim