Rrd4j persistance stopped working and can't figure out what happened

I have been using persistance to graph all my in-house temperatures to see where I need to tweak our new heating system. It’s been working fine for the last several months.
Recently I’ve been creating some new rules where I wanted some items value remembered after startup, so I tried adding:

* : strategy = everyUpdate, everyMinute, restoreOnStartup

but I threw a strange error, and so I removed it again like it was before and thought everything was fine. Now I noticed my temp graphs haven’t been updated for a week or so (probably since I tried to change the persist file). But I can’t seem to get it work like before. I tried uninstalling/reinstalling rr4dj persitance. My persist file is:

Strategies {        
    everyMinute : "0 * * * * ?"
    default = everyChange

Items {
    * : strategy = everyUpdate, everyMinute 
    gTemp* : strategy = everyUpdate, everyMinute

But when I save I do get this message all the time (tried removing and rewriting first line/charcters):

09:12:50.532 [INFO ] [del.core.internal.ModelRepositoryImpl] - Loading model ‘rrd4j.persist’
09:13:10.386 [WARN ] [del.core.internal.ModelRepositoryImpl] - Configuration model ‘rrd4j.persist’ has errors, therefore ignoring it: [1,1]: mismatched input ‘’ expecting ‘Strategies’

09:13:10.548 [WARN ] [tence.internal.PersistenceManagerImpl] - Failed to delete cron job for dbId ‘rrd4j’

am I missing something?

I think, if you have the line

  • : strategy = everyUpdate, everyMinute

alle items are persist and you don’t need

gTemp* : strategy = everyUpdate, everyMinute

Sometime restarting openHAB after a change helps.

Additionally the documents still have the note about removing the old .rrd files in order to make it work again.

oops… rtfm i guess :blush: thanks, will give that a try!

Mmm… deleted the files but didn’t help so far. So I uninstalled rrd4j persistance, then deleted all the files. And reinstalled persistance. All new files are created in the folder, but my graphs don’t update. Also when I change something in the rrdj4.persist file I still get that strange error, although it says it’s a warning.

13:03:25.108 [WARN ] [tence.internal.PersistenceManagerImpl] - Failed to delete cron job for dbId ‘rrd4j’
13:03:25.214 [INFO ] [del.core.internal.ModelRepositoryImpl] - Loading model ‘rrd4j.persist’

Did you check via the REST API if you have valid entries in the database? That way the problem could be nailed either to the database (no valid entries) or to the creation of the graph.

A “warning” is no error, in other words I suspect you have valid entries in the database.

09:13:10.386 [WARN ] [del.core.internal.ModelRepositoryImpl] - Configuration model ‘rrd4j.persist’ has errors, therefore ignoring it: [1,1]: mismatched input ‘’ expecting ‘Strategies’

Looks like there is a rogue character at the beginning of your persist file.
Stop OH
Delete the file
Write it again - from scratch if possible - avoid the copy and paste as you may copy that character - make sure you use a simple text editor nano will do
Start openhab

1 Like