Rule Engine (Experimental) Installed but No Button/Menu in PaperUI

Tags: #<Tag:0x00007fc8fafaa008>

Been updating my openHAB 2.5 installation (2.5.6). Have been using a few basic rules in the Rule Engine under Paper UI.

Menu “Rules” is no longer visible under PaperUI and the rules are not functioning.

Tried uninstalling the add-on and re-installing but no difference.

Am I missing a step somewhere? The standard rules I wrote via CLI are operating normally however the ones written in the PaperUI add-on are not.

Thank you in advance!

There is nothing else needed beyond installing the add-on. Do you see any errors in the logs?

Here is a pastebin of a log dump (var/log/openhab2/openhab.log):
https://pastebin.com/yZkTbYQV

Thank you,

I can’t open pastebin from my work network and my phone is pretty much useless for reading logs. Go through the logs, look for lines that have the word “ERROR” and report what they are or if there are any.

rlkoshak,

Here’s the first line I saw in the log as I committed the ‘Install’ operation. It looks like it may have repeated a few times.

2020-06-23 20:13:21.931 [ERROR] [org.openhab.core.automation         ] - bundle org.openhab.core.automation:2.5.0 (273)[org.openhab.core.automation.internal.type.ModuleTypeRegistryImpl(461)] : The activate method has thrown an exception

Hopefully that is viewable, appreciate the help!

What version of Java are you using (1.8.0_252) and have you tried clearing the cache?

And take a look in this topic…

I attempted clearing cache referencing: Clear the Cache

Seemed to generate similar errors.

Removed my /var/lib/openhab2/jsondb/automation_rules.json and associated backup files (nothing I can’t easily re-create fairly easily)

Uninstalled the Add-On, shut down openHAB2, cleared cache, resarted openHAB2, attempted to install the Rule Engine addon and got the following same/similar error repeating multiple times:

2020-06-25 00:33:37.794 [ERROR] [org.openhab.core.automation         ] - bundle org.openhab.core.automation:2.5.0 (263)[org.openhab.core.automation.internal.type.ModuleTypeRegistryImpl(357)] : The activate method has thrown an exception

Scratching my head on this one. Installing or Uninstalling this Add-On from the PaperUI generates a slowly turning progress wheel (like expected) however it never stops. Refreshing the page shows it appropriately installed (or not) however nothing in the menu structure on the left still.

  • Update to 2.5.6-2
  • Shutdown OH
  • Clear cache
  • Backup jsondb and the archive to another directory
  • Restart OH and wait for things to settle
  • Restart OH a second time

If you get the rules menu, look through your jsondb rules and figure out what is corrupt (or post them). If not, backup everything and start fresh.

My bet is on something corrupt in the jsondb.

1 Like

Following these recommendations (post above) Rules is now visible in PaperUI. The jsondb backup and refresh is going into my list of things to do if I’m having issues.

Thank you 5iver!

1 Like