Rule files not reloaded and timer not working


today I encountered a strange behavior, I have never seen before.

First I noticed, that my blinds where not moved up in the morning. The rule fired, but the timer function started by this rule was not executed ( I am using Jython rules with python threading.Timer timers)

There was no log message from the function called by the timer (it logs in every execution path) and no other error message in the logs.

Then I tried to debug this problem and started a timer in the rule file, outside a function. The timer was created after the file was reloaded by openhab but the timer function was not called.

While doing some more testing I noticed, that openHAB stopped reloading changed files, even when they where changed in the shell using joe. After restarting openHAB everything was working as expected.

I am using openHAB 2.4, the Jython rules worked for several month without such a behavior.


The ScriptEngine can crash… I’ve managed it while testing things. So, you may be reporting two separate issues, but it could also have been a hardware issue. Without logs, there’s no way to know what was going on.

The scripting engine seemed to be OK, as other rules where executed, only the timers had a problem.

I could find no hint whatsoever in any log file…

This is a symptom of the ScriptEngine (different than rule engine) crashing. If other rules were still executing at this time, then this was not the case. ScriptFileWatcher checks for new.changed scripts every 20 seconds IIRC. If there were no threads available, an issue with your internal clock, or the scheduler was hung, then this could be related to the timer issue.

Thanks for the input, I guess I have to monitor this and try some more testing if this ever happens again… Never had this before with openHAB!