Rules: Cryptic-and-Cut-Error-Message


I tried creating Scenes with a Fake-Switch and rules.

The two items have following code:

Dimmer 200_Light_RGBW  "Licht Rohr"                        { knx="8/1/48" }
Switch          Bastard_Cinema                      "Heimkino"           { knx="0/0/0" }

The 200_Light_RGBW is working p. ex. out of HabPanel. But not from the rules:

rule "CinemaScene"
  Item Bastard_Cinema received command ON

It happens nothing but an entry in my log-file:

2017-08-23 22:33:34.046 [ERROR] [.script.engine.ScriptExecutionThread] - Rule 'CinemaScene': An error occurred during the script execution: The name 'ight_RGBW' cannot be resolved to an item or type.

Renaming the Item does not solve it - even the simple name like lightrgbw has the same effect.
The was never every anywhere a item like ‘ight_RGBW’… :-/

If i use another item, like a normal light, it works without error. P. ex. ‘Light_EG_108_Hifi’ works.

Any tip for me and my strange problem?


Why is your item called 200_Light_RGBW but your rule uses 201_Light_RGBW?

Ups… sorry, copied the wrong line:

Dimmer 201_Light_RGBW  "Licht Flur"                        { knx="8/2/48" }

But with the 200 happens the same :slight_smile:

How do you edit your rules and items files? I’m pretty sure there is a typo over there - probably far away from the rule itself… :wink:

What is the “same effect” in this case? You see error for ‘ight_RGBW’ or for ‘trgbw’ or something?

just to finish this:
I solved it by using another editor. I used microsoft code … afterwards i began with eclipse.

Thanks everyone!