Rules don't trigger - Kubernetes openhab docker

Hello,

i am using the latest docker release of openhab3 and am experiencing an issue with the rules not triggering.
It doesn’t matter wich triggers i’m using. (time-based triggers, item based triggers, thing based triggers).
The debug log shows that the state of the item has changed, but the rule is not executing.

Kubernetes is running on an pi cluster consisting of 2 pi’s.
I already tested it with an older Version of openhab, to rule out bugs in the current version.

The state of the rule is staing at “IDLE” all the time.
If i click on “test the rule” it works.

Let me know, if you need more information.

Thank you.

How are your rules defined? Which language? How do you know they are not triggering (logs in the rules, change events.log to include rule events, etc.)? Which OH 3, OH 3.4.1?

I defined my rules in the UI. My Version is 3.4.1. But i also tried it in Version 3.2.0, with the samne result.
For Example:
I created myself a dummy Item called “debug”.
i created a Rule, that triggers when my Windows sensor changed its state. The Dummy Item state should be “Open” but it stays “NONE” until i run the Rule manualy.
I Also experimented with time based triggers (every 1 Minute) but same result.

Post one of these rules (click the code tab and use code fences).

```
code goes here
```

Do you see anything in the logs during startup related to these Items or rules?

Add some logging to the rule. It seems likely that the rule isn’t running but it’s also possible that it’s failing to update the Dummy Item and without logs we would never know the difference.

How does the Dummy Item get the state of NONE?

Since it happens both in 3.2 and 3.4 there is almost certainly something wrong with your rules, OH config, or there is something about running in Kubernetes that breaks something (unlikely but because OH usually has to interface with physical hardware, any benefit to running in Kubernetes is minimal so few bother).

Sorry its “NULL” not “NONE”.

If i’m honest, i don’t know where to find logs.

Code:

configuration: {}
triggers:
  - id: "1"
    configuration:
      itemName: Thermostat_PCZimmer_Zieltemperatur
    type: core.ItemStateChangeTrigger
conditions: []
actions:
  - inputs: {}
    id: "2"
    configuration:
      command: Changed!
      itemName: Debug
    type: core.ItemCommandAction

Above you said the Item was debug but here it’s Debug. Case matters. Are you sure that’s right?

Above you say you are expecting the dummy Item to become “Open” but here you are sending Changed! as the command.

It depends on how you installed OH. Since you are running it on Kubernetes, it will be in userdata/logs where userdata is what ever volume you mounted into the container under /openhab/userdata.