Rules Not Firing For Contact Item

I have a ZWave tilt switch on the garage door that is defined as a contact type item, thus:

Contact	Garage_Door_Right			"Garage Door Right"					<u-garage->	(G_Garage, G_Sensors)				{channel="zwave:device:7c87f974:node7:sensor_binary"}

The very simple test rule is:

rule "Garage_Door_Right_Open"
    Item Garage_Door_Right changed
	logInfo("Garage Door Right", "State NODE 7:" + Garage_Door_Right.state)

However the rule never fires. If I change it to a switch type item the rule fires as expected. This device fires the rules on OpenHab 1.8.3 when defined as a contact type.

I’m running a snapshot from yesterday on Windows 10. I can see the status of the tilt switch changing on the control page in the PaperUI. I turned on debug logging and didn’t see anything unusual.

Have you tried:

Item Garage_Door_Right received update


Item Garage_Door_Right received command OPEN

Hi Paul,

Good suggestions, no I had not tried those.

This is what I found:

  • Using"received update" worked with the item defined as switch but not as contact.

  • I couldn’t get the rule to fire at all using “received command”, but I think that is to be expected since I wasn’t sending any commands to the device.