Rules stopped working altogether in Openhab 3


I have been running Openhab 3 for quite a while now (new setup, no migration from 2.x) and my rules have been working fine. They stopped working all of a sudden, unfortunately I can’t pinpoint exactly when since they haven’t been in use for a while, I only noticed when I tried adding a new rule.

The problem is: when the rules are triggered manually for testing purposes, they run fine. But the actual triggers don’t trigger, neither time nor event-based. I tried all sorts of different items as well, no rule will fire and I don’t see anything in the logs either.

Has anyone run into similiar problems or any idea how to fix this? It’s been bugging me for days now and I can’t find a solution.

Best regards,

Hi Manuela,

I also faced this issue some time ago.
Unfortuanteley I was not able to find the root cause. (But it did not happen again.
What I did:

Stop OH
empty /openhab/userdata/tmp and cache folders
Restart OH

Hope it helps

Hi Franz,

Oh my, that was it! Thank you so much!

Note, the procedure that @FranzS described is implemented by openhab-cli clean-cache, if you’re installed on a Linux machine and have installed OH using apt/yum/etc. This also applies to openHABian.

What this does is force the reinstallation of all the add-ons and bundles.