Rules using UTC instead of local time zone

  • Platform information:
    • Hardware: Intel NUC J4005, 4gb RAM
    • OS: Ubuntu Server 18.04 LTS
    • Java Runtime Environment: openjdk version “1.8.0_242”
    • openHAB version: 2.5.1

Hello openhab community =)
i started using openhab two weeks ago and yesterday i tried to manage my shutters with some rules, e.g:

rule “Tag_Rollo_ab”
Time cron “0 0 19 1/1 * ? *”

it should let my shutters down at 19:00 / 7pm. But in fact, my shutters are closing at 20:00 / 8pm.

Local time: Mi 2020-02-19 18:14:06 CET
Universal time: Mi 2020-02-19 17:14:06 UTC
RTC time: Mi 2020-02-19 17:14:06
Time zone: Europe/Berlin (CET, +0100)
System clock synchronized: yes
systemd-timesyncd.service active: yes
RTC in local TZ: no

it seems like cron/rules are using universal time instead of of local time. i tried to find a solution to change it on google, but couldnt find anything. Openhabian-config shows the correct time.
Did someone had the same problem and/or knows any solution? Of course it would be easy to just set rules time to 6 pm, but daylightsaving-time would mess anything up.
Kind regards,

Edit: changing BIOS time seemed to be the Trick, its working now (until daylightsaving-time Kicks in…)

Welcome to the forum! A quick search turns up…

Thanks for you reply. But this guy had a different problem =( His Linux Locale Time wasn´t set correctly, mine is.

As I mentioned, it was a quick search… there were other related topics that came up too :slightly_smiling_face:. My point was that others have reported similar issues which have been discussed in the forum. Your OP does not list any troubleshooting steps, so you may want to start there.

What do you have your OH regional settings set to?