Run as windows service, missing items and things


I’m running openHAB 2.2 on a Windows 10 server. I’m new in home automation and first I started start.bat and setup every zwave hardware I have.

After that I wanted to create the openhab service like described in the docu. After a bit struggling with the wrapper.conf, I got managed to run openhab as a service. But when I run it as a service, my items and things are missing. I dont know why.

Thx in advance for help!

nobody any idea why I’m missing items, things etc when I run openhab as service instead of batch file? :S

2020, updated to 2.5.1, installed new service with wrapper and the error still exist :confused: seems that jsondb will not get loaded correctly…

well I did it now like described here and copied the whole wrapper.conf file:

the problem is, that after installation in the default openhab2-wrapper.conf the wrapper entry is missing.

Additionally, the -Dfile.encofing=UTF-8 is missing in the default file and also in the link I wrote above.