Russound/2.4


(Tim Roberts) #1

On 2.4 stable - when I try to install my Russound binding, I get the following error in the logs and I was hoping someone can give me a clue on it (as the error message doesn’t make much sense to me):

2019-01-22 08:30:11.465 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-russound': Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-binding-russound; type=karaf.feature; version="[2.4.0,2.4.0]"; filter:="(&(osgi.identity=openhab-binding-russound)(type=karaf.feature)(version>=2.4.0)(version<=2.4.0))" [caused by: Unable to resolve openhab-binding-russound/2.4.0: missing requirement [openhab-binding-russound/2.4.0] osgi.identity; osgi.identity=org.openhab.binding.russound; type=osgi.bundle; version="[2.4.0,2.4.0]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.binding.russound/2.4.0: missing requirement [org.openhab.binding.russound/2.4.0] osgi.wiring.package; filter:="(osgi.wiring.package=org.apache.commons.net.util)"]]

I think it’s complaining about org.apache.commons.net.util missing - but am really unsure on this message


(Tim Roberts) #2

Just as an FYI - was complaining about that jar. Once added - binding worked…