Samba for Openhab directory not working like it should

i made a samba share from my openhab directory (ubuntu) to edit the config files with my windows computer.

This is what i changed in the smb.conf

wins support = yes

comment = OpenHAB
path = /usr/share/openhab/
browseable = Yes
writeable = Yes
only guest = no
create mask = 0777
directory mask = 0777
public = yes

I can edit all configuration files directly with my windows computer.

But i can not copy new addon-files to my openhab installation. I get an error message, that i have not the rights for this.

If i use WinSCP, i can copy addon files with no problems.

Is there something missing in the samba configuration? 777 for the whole openhab-directory is the best i can do?

Copying works on my side with:

path = /opt/openhab2
available = yes
read only = no
browseable = yes
public = no
writeable = yes
force user = openhab
force group = openhab
create mask =0777
directory mask=0777
guest ok = no


There someting more to it then the change’s in the smb.conf file :slight_smile:

Look Here:

And use the right pad (see the openhab docs)


I run OH2 an a odroid U3. I installed it as described in the manual.
As recommended, i tried to activate samba to work on the configuration via my windows machine.

Below are my setting and

workgroup = WORKGROUP
wins support = yes

comment=openHAB2 userdata
only guest=no
create mask=0777
directory mask=0777

comment=openHAB2 site configuration
only guest=no
create mask=0777
directory mask=0777
read only=no
force user=root

I can see the folders on my windows machine, but its not possible to mount it as drive as you can see in the atteched Dok1 file.

I tried to connect with my android phone and it worked within a second.
I don´t see the mistake, an hope you can help me.

THXDok1.pdf (126.3 KB)

something is not working with the network shares mapping on your Windows PC…
(by the way, I saw that you tried to map it to the Y:\ drive letter but the error is showing Z:\ )
Using google xlate, I see that you get an error of the following kind: “The local device is already being used” (der lokale gerätename wird bereits verwendet)

Check the following in a command line in your windows pc:

net use

and remove any existing network mappings from the drive letter that you are trying to use in advance:

C:\>net use Y: /d
Y: was deleted successfully.

Then, try to map the samba share again

Hi Dimitris

that is, because the screenshots where taken from different attempts. I tried the whole ABC :slight_smile:

I deleted the drive yesterdaym but i will try it again today.

That is really annoying that these little steps take so much time.