Samsung TV Binding - all of a sudden sourceName doesnt work

I have changed no code; last night I was able to control my TV.
Tonight, when i go to switch the source, i get an error in the log

What would cause this?
Volume still works, power still works…the sources no longer work.

I’m lost. i don’t update TV firmware etc.
I haven’t updated openhab.
i haven’t edited the items files or site map.

Frame label=“TV” {
Slider item=LRTV_Volume label=“LRTV Vol” switchSupport sendFrequency=1000
Switch item=LRTV_Source label="" mappings=[TV=‘TV’,“HDMI1/DVI”=‘CC’, HDMI2=‘Roku’, HDMI3=‘Ant’, HDMI4=‘XB’, AV2=‘AV’] icon=“none”
Switch item=LRTV_Source label=“LRTV Source” mappings=[TV=‘TV’]
Switch item=LRTV_Source label=“LRTV Source” mappings=[“HDMI1/DVI”=‘ChromeCast’]
Switch item=LRTV_Source label=“LRTV Source” mappings=[HDMI2=‘Roku’]
Switch item=LRTV_Source label=“LRTV Source” mappings=[HDMI3=‘Antenna’]
Switch item=LRTV_Source label=“LRTV Source” mappings=[HDMI4=‘XBOX’]
Switch item=LRTV_Source label=“LRTV Source” mappings=[AV2=‘AV2’]
Switch item=LRTV_Power label=“LRTV_Power”

Switch TV_Mute { channel=“samsungtv:tv:f6a331f7_e98a_ece9_6278_c9157ab147a3:samsungtv:tv:livingroom:mute” }
String TV_KeyCode { channel=“samsungtv:tv:f6a331f7_e98a_ece9_6278_c9157ab147a3:keyCode” }
Dimmer LRTV_Volume { channel=“samsungtv:tv:f6a331f7_e98a_ece9_6278_c9157ab147a3:volume” }
String LRTV_Source “Source” {channel=“samsungtv:tv:f6a331f7_e98a_ece9_6278_c9157ab147a3:sourceName”}
Switch LRTV_Power “Power” {channel=“samsungtv:tv:f6a331f7_e98a_ece9_6278_c9157ab147a3:power”}

So…not sure why this fixed it…but.
I unplugged and replugged the TV, rebooted Openhab and the network cable on the TV.
I could then change the source name.

volume always worked
power always worked
i only lost the source ability until doing that.


Samsung TV’s publish multiple UPnP devices to network. Amount depends on TV model. Binding support TV features dynamically, meaning binding support only TV features which has been discovered. Some reason binding didn’t discovered MainTVAgent2 UPnP device from your TV, and thats why source name channel was not supported.

It’s weird because it’s always worked…i haven’t updated the TV or openhab.
I noticed that power cycling the TV fixes it temporarily.

Actually all i have to do is unplug, replug in the network cable to the TV and it starts working again for an hour or so.

When it stops working, i still have control over volume and power, just not sources.
Do the plug thing…and it all works again.

I’m perplexed.

As I said earlier, MainTVAgent2 UPnP device provides Volume functionality. Power and volume are controlled via another UPnP devices.

You could change Samsung TV binding and UPnP transport bundle logging level to debug to get more information.

From Karaf console (untested commands)

log:set DEBUG org.openhab.binding.samsungtv
log:set DEBUG

Did you guys get it solved? I’m still facing an issue, message is that Source is not supported