Samsung TV Binding (Beta)

@rpwong

Well that’s odd then. Do you have access to a computer that can send WOL packets via another method (there are several apps for Windows and iPhones/Pads/Android). it might just be the wrong MAC address or something. it’s easier to experiment with a dedicated app than it is to keep messing with the binding settings.

The TV should turn on when it receives the WOL packet correctly.

Maybe post the output from http://192.168.1.93:8001/api/v2/ when the TV is on, just to see what it says.

Here you go.

Something I just noticed is that there’s a different UID in this output from the UID in my SmartThings account (see screenshot above).

{"device":
{
 "EdgeBlendingSupport":"false",
"FrameTVSupport":"false",
"GamePadSupport":"true",
"ImeSyncedSupport":"true",
"Language":"en_US",
"OS":"Tizen",
"PowerState":"on",
"TokenAuthSupport":"true",
"VoiceSupport":"true",
"WallScreenRatio":"-1",
"WallService":"false",
"countryCode":"CA",
"description":"Samsung DTV RCR",
"developerIP":"0.0.0.0",
"developerMode":"0",
"duid":"uuid:a83f5c74-8f72-4927-b3c3-15658b67ed4d",
"firmwareVersion":"Unknown",
"id":"uuid:a83f5c74-8f72-4927-b3c3-15658b67ed4d",
"ip":"192.168.1.93",
"model":"23_PONTUSM_QTV",
"modelName":"QN50QN90CAFXZC",
"name":"Samsung QN90CA 50",
"networkType":"wireless",
"resolution":"3840x2160",
"smartHubAgreement":"true",
"ssid":"a0:40:a0:7d:e0:26",
"type":"Samsung SmartTV",
"udn":"uuid:a83f5c74-8f72-4927-b3c3-15658b67ed4d",
"wifiMac":"BC:45:5B:AE:0A:4C"
},
"id":"uuid:a83f5c74-8f72-4927-b3c3-15658b67ed4d",
"isSupport":"
{
\"DMP_DRM_PLAYREADY\":\"false\",
\"DMP_DRM_WIDEVINE\":\"false\",
\"DMP_available\":\"true\",
\"EDEN_available\":\"true\",
\"FrameTVSupport\":\"false\",
\"ImeSyncedSupport\":\"true\",
\"TokenAuthSupport\":\"true\",
\"remote_available\":\"true\",
\"remote_fourDirections\":\"true\",
\"remote_touchPad\":\"true\",
\"remote_voiceControl\":\"true\"
}
\n",
"name":"Samsung QN90CA 50",
"remote":"1.0",
"type":"Samsung SmartTV",
"uri":"http://192.168.1.93:8001/api/v2/",
"version":"2.0.25"
}

@rpwong

Yes the UID is not the same as the Smartthings device Id. I’ve never seen "ssid":"a0:40:a0:7d:e0:26", before, but both my TV’s are wired. the MAC address seems correct though.

Is that actually your WiFi ssid?

I didn’t even notice that. It is not my SSID. I suspect it’s the MAC address of one of my mesh APs.

I can try running a LAN cable to my TV (and disconnecting my soundbar) to see if it works that way. Would that tell us anything?

@rpwong

Sounds like a lot of effort. I’m just wondering if the WOL packet isn’t being broadcast properly by your mesh WiFi- seems unlikely though, broadcast is a fairly common event.

a0:40:a0:7d:e0:26 is a Netgear MAC address for what it’s worth. Are you using Netgear routers in AP mode? if so, shouldn’t they all be broadcasting the same ssid?

Anyway, I’m fairly sure the TV should support WOL, so it’s probably some sort of networking weirdness.

Yep, it’s a Netgear Orbi in AP mode. I’ve confirmed that that’s the MAC address for the 2.4G band on my main Orbi unit. I’ve no idea why it would show up that way to the TV, though. I tried disconnecting and reconnecting the TV, and it’s still the same.

I’ll try another WOL app to see what happens. Any recommendations for Windows and Android?

@rpwong

I use a windows app called - “Wake on Lan (magic packet)”, no idea about Android, I have Apple stuff - there is probably a ton in the play store though.

I found one on Android and was able to send a packet to the TV. The app confirmed that it was sent/received and pinged the TV to confirm it’s online, but the TV didn’t actually turn on.

Networking!

@rpwong

Looks like it. One of my TV’s is wired with a soundbar, so I use an IR blaster to turn it on. the other doesn’t have a soundbar, but it’s a 2022 frame TV, and that never actually drops the network connection, so I can always turn it on and off.

Thanks for the help.

Thanks to you for all of your work on this! I use a Harmony Hub anyway, and just want to help with the testing.

@rpwong

Actually my “IR blaster” is a harmony hub as well. I have it set up in OH with the harmony binding, and just send the TV “POWER” key via harmony IR when the TV on button is clicked in OH.

1 Like

Hi ,
I m facing issue with the binding. Every time my TV is powered off and then on, binding stops working. What I have observed is I have to give openhab permission every time TV is disconnected from power or OpenHAB is restarted.

I m talking about Connection Manager on Samsung TV setting to allow openhab to have access for sharing content.

In setting it says allowed but seems it needs to be allowed to have access every time there is power cycle of either openhab or TV.

Anyone facing similar issue.

OK Sure.

??? What do you want to tell us ?

@tizen

Regarding the request for confirmation on the TV every time, that can be a setting on the TV. you can set it in “device manager” to Always, First time only, and Never. You may have it set to “Always”, I recommend setting it to “First time only”.

After each power cycle or OpenHAB restart, you need to grant permission in the Connection Manager settings on your TV for OpenHAB to access content. Even though the setting indicates it’s allowed, it requires reauthorization each time. This suggests a persistent permission problem that might be related to the TV or OpenHAB setup. Check if there are any updates for your TV firmware or OpenHAB version that could potentially address this issue.

Hi,

I dont know my exact modell at the moment, but my tv is 4 years old I have the same problem that i must grant permission again after each restart…

Thanks for the reply. Let me check this option

Thanks for the reply. I have two samsung tv and both are having latest software version. In fact one is just few months old. My openhab version is 4.x stable version.

Giving permission everytime defeats the purpose and the automation also does not work reliably.

@tizen

Can you post a TRACE level log of the samsungtv binding, because this is not supposed to be how the binding works.

When you authorize the binding to connect, the tv returns a token (just a sequence of numbers), which the binding stores in the thing configuration.

The next time the binding connects, the same token is used to connect, and you should not get asked to authorize again.

The only way the token would be invalid is if an ip address changes, or you have the thing defined in a text file, and haven’t entered the token in the thing configuration.

Is your TV thing defined in a text file?

Also, what is the output of http://ip:8001/api/v2/