Samsung TV UA75 basic UI

Hi all,

This is my first post as a beginner.
I have read a lot of posts about the samsung tv, but it is not working for me.
On my qnap nas I have installed openhab 2.2. Also I installed the binding for the Samsung TV
Then I created the default.things file, default.items and default.sitemap files in the conf/things, conf/items and conf/sitemap maps
They contain following:
default.things
Thing samsungtv:tv: [ hostName=“xxx.xxx.xxx.xxx”, port=55000, refreshInterval=1000 ]
default.items
Group Huiskamer
Switch TV_aan_uit “TV_aan_uit” (Huiskamer){channel=“samsungtv_tv_09896803_00a0_1000_adfd_90f1aacaae67_power”}
Dimmer TV_Volume “TV_Volume” (Huiskamer){channel=“samsungtv:tv:09896803_00a0_1000_adfd_90f1aacaae67:volume”}
default.sitemap
sitemap mijn_huis label="[TV]Samsung_LED75"
{
Frame label=“TV” {
Switch item=TV_aan_uit
Slider item=TV_Volume

	    } 

}

When I go to the basic UI I can see the buttons, but they don’t work

Can anyone tell me what I am doing wrong?

Thanks

Have you tried looking in the log file?
Do you know what is logged?

(You can find how to log onto the log command line here https://docs.openhab.org/administration/console.html
after you logged on type log:tail to see wat is happening when you click the buttons

This is what I found in the openhab log file.
Binding configuration of type ‘channel’ of item ‘TV_aan_uit’ could not be parsed correctly.
org.eclipse.smarthome.model.item.BindingConfigParseException: UID must have at least 4 segments.

So now I must find out, what I have to add.
Update: I added 4 items now. But now I get this error:
Error was reported: Could not send command to device on xxx.xxx.xxx.xxx:55000
org.openhab.binding.samsungtv.internal.protocol.RemoteControllerException: Connection failed.

There are a lot more sub errors, but first I have to solve this one.
and now I get this error:
An error occurred while calling method ‘ThingHandler.handleCommand()’ on ‘org.openhab.binding.samsungtv.handler.SamsungTvHandler@54001f85’: Command ‘100’ not supported
java.lang.NumberFormatException: Command ‘100’ not supported