Satel binding - support, announcements and feature requests

No, I didn’t. Check the date in the console :wink:

Sometimes it is good to start from the scratch.

I didn’t want to merge this without being sure it solves your issue. I will do it asap.

:slight_smile: sure just trying to understand. Your binding as a version of 2.5.5.xxxx maybe that could be something as I was on 2.5.4 before?
Though I did tests in a fresh setup, I have been running now for about 24h on my other system (only cleaned not from scratch) and it works just fine.

Thank you very much for debugging this with me all the way and your effort!
I am really glad this works now :slight_smile:

1 Like

I was not able to upgrade from 2.4.0 to 2.5.5. I had ETHM-1 in ver. 1.06 , I tried to upgrade it to ver. 1.07 with no luck, so in the next step I decided to replace ETHM-1 with ETHM-1 Plus, after that I made upgrade with no problem. So it seems that previous problem with upgrading from version 2.4.0 was connected with ETHM-1 ver. 1.06 .
And one thing more, I am not sure about this because and the same time I realized that version of Satel firmware was from 2016 year so I made an upgrade in my Integra 32 also.

What was the problem? Did you have problem with upgrade or with the binding after upgrade?

The problem was similar like upgrade from 2.4.0 to 2.5.4 , it was disconnecting every 5 seconds , I missed that because I had many logs with minor problems about some other items, after some time I realized that the connection to Satel does not work properly. I control pump for hot water by PIR’s from Satel and I had cold water :slight_smile:
I made also upgrade in my company where I have 9 Satel systems connected to OpenHab and the upgrade was fully successful. There are only ETHM-1 ver. 1.07 or ETHM-1 Plus.

Have you read @sim0nx post? 2.5.5 does not contain “extCommands” option yet. You still need the marketplace version of the binding.
Also you have to set this option to false for 1.06. So it does not start working after upgrade, you have to configure it first to make it working.

Processing log entries from satel integra, IF there is a log entry ot LowBattery normalization (ON ->OFF, after I replaced old battery in wireless satel sensor) there is an error in log:
- openhab: report: 2020-08-24 18:27:37.160 [INFO ] [el.internal.handler.SatelEventLogHandler] - Unsupported device kind code 32 at index -1

The message (description XXX details) was:
​2020-08-24 18:05: Bateria wejścia radiowego ok XXX kind=32, partition=1, source=10, object=0, ucn=0

Was it zone or output #10 and partition #1?

Yes, input zone no 10 and partition 1.

Hi! Is there any chance to use Satel Binding with Integra System connected via INT-GSM?
I have remote access to the system via Integra Control app using “Satel Server”.

Can I use the “Satel Server” in the binding?

Hello Piotr.
I don’t think it supports integration protocol used in the binding. At least there is no mention about it on Satel web site.

I have the same issue with newest version of binding from marketplace:

openhab> bundle:list | grep Satel
302 │ Active │ 80 │ │ openHAB Add-ons :: Bundles :: Satel Binding

I have Satel ETHM-1 firmware 1.7

Łączę z serwerem: 192.168.2.XXX:ZZZ
Nawiązuje połączenie
Moduł: ETHM-1 V1.07
Jest połączenie.
Połączenie TCP/IP: 00:02:16

in my things file i have set option extCommands to false:

Bridge satel:ethm-1:dom [ host=“192.168.2.XXX”, port=“ZZZ”, refresh=1000, userCode=“YYYY”, extCommands=“false” ]

and still reconnect loop in logs

2020-09-08 10:42:22.965 [INFO ] [.satel.internal.protocol.Ethm1Module] - Connecting to ETHM-1 module at 192.168.2.XXX:ZZZ
2020-09-08 10:42:22.977 [INFO ] [.satel.internal.protocol.Ethm1Module] - ETHM-1 module connected successfully
2020-09-08 10:42:22.977 [DEBUG] [.satel.internal.protocol.SatelModule] - Sending message: Message: command = 7E, payload =
2020-09-08 10:42:22.977 [TRACE] [satel.internal.protocol.SatelMessage] - Calculated checksum = D860
2020-09-08 10:42:22.977 [TRACE] [.satel.internal.protocol.SatelModule] - Waiting for response
2020-09-08 10:42:22.991 [INFO ] [.satel.internal.protocol.Ethm1Module] - Closing connection to ETHM-1 module
2020-09-08 10:42:22.991 [DEBUG] [satel.internal.event.EventDispatcher] - Distributing event: org.openhab.binding.satel.internal.event.ConnectionStatusEvent: connected = false, reason = null
2020-09-08 10:42:22.991 [TRACE] [satel.internal.event.EventDispatcher] - Distributing to org.openhab.binding.satel.internal.protocol.Ethm1Module@4bbaaa90
2020-09-08 10:42:22.991 [TRACE] [satel.internal.event.EventDispatcher] - Distributing to org.openhab.binding.satel.internal.handler.Ethm1BridgeHandler@60ce80b3
2020-09-08 10:42:22.992 [DEBUG] [.satel.internal.protocol.SatelModule] - Communication thread stopped

I checked also config with extCommands set to true but nothing changed, same errors.

System (2.5.8 in docker) is set up from scratch, only few bindings, no sitemap, no rules. Just after 2.5.8 binding installation, connection was working but from today morning it suddenly stopped and reconnect loop appeared. Any help would be appreciated :slight_smile:

Is this the only client connection to ETHM-1 using integration protocol? Only one client at the time can connect to ETHM-1.
If yes, try to disconnect ETHM-1 from the network by pulling out the wire or power cycling the module.

I hope it will help.

Hello druciak

Would you kindly look at the issue described in my post: :slightly_smiling_face:
The doc states that satel binding shall work with INT-RS/INT-RS Plus but I have an impression that it does not work with INT-RS

In this thread above I have found similar issue of repetitive disconnecting related to ETHM-1, for which you have implemented some fix. I an wondering if this would be possible for INT-RS or it is not longer supported?

Hi Rafał,
thanks for the info, I sometimes search the community for keyword “satel”, but the best idea is to post any issues here, or at least mention me in the post, so I get a notification.

The main problem with INT-RS is that I don’t own any, but there was somebody with this module in the past and we managed to get the binding working with his module. This was some time ago and I have no idea if it still works, but I hope it does.
However from your log in the other thread it seems the module does not respond to 7E command at all. According to the documentation the latest INT-RS version is 1.14, you mentioned 1.4, maybe this is the problem. Also you have additional hardware (a converter) between the module and your OH machine, are you sure it works? Did you test it somehow?
I will try to help you, but it is really hard to find the issue remotely. Anyway I am happy to help.

It is good idea to tag topics with satel tag to which everyone can subscribe. :wink:

1 Like

Thank you for response. I think I have made mistake and the version of INT-RS was 1.14. This seems to be the last version before INT-RS Plus. I am now away but next week shall be back to check it and try to find some test for converter I have put together. Will let you know!

I am back at investigation :wink:

I have INT-RS version v 1.14 2016-03-09. It seems to be last available version of the firmware before the next one released for INT-RS Plus (v2.18 2018-01-11)

I have checked my RS232-USB converter using loop-back test and in both windows and Linux it works (I can see echo using puTTY and both RX and TX LEDs are flashing)
When attached to OpenHab I have noticed that the TX LED of the converter flashes from time to time which seems to be “trying to connect”/sending signal from Satel binding/Openhab? But no response from Satel INT-RS :frowning:

Also I have set up another converter translating RS 232 to Wifi/Ethernet (Max2323 + ESP8266).
But after connecting (via ETHM-1 binding) I have similar messages: opening and closing connection.

I can not find any options in DloadX related to INT-RS setup. Seems it shall work out of the box (and it works currently with my PLC using Modbus RTU protocol)

Hence, I am close to conclude that the binding does not support INT-RS. You have mantioned about smb from the forum using INT-RS not sure if was not INT-RS Plus?