Schedule rule don't start openhab 3 docker

hi every body i’m new in the community but i discovered openhab since openhab v1
i d’ont use it before because of programmation file now that done with UI it’s more easy :joy: maybe more buggy :sweat_smile:

  • Platform information: Synology ds418play 2GB Ram in docker
    • Hardware: CPUArchitecture/RAM/storage cpu Intel Celeron J3355 Dual Core ( 2 GHz - Turbo 2.5 GHz) 2GB RAM DDR3 60% of use
    • OS: what OS is used and which version DSM 6.2 (Docker)
    • Java Runtime Environment: which java platform is used and what version (last with Docker)
    • openHAB version: 3
  • Issue of the topic:
    i create a schedule rule with a send command “OFF” to an item
    when i try the rule with play button the rule work great
    but it don’t start at the specified time

i verify the openhab log and the event log
there are no error in openhab log
in event log i don’t see the rule star but i see each time that i modify the schedule rule ( was saved each time)
i try multiple time, i modify schedule each time to report about 10 min later after unsuccessful try
but never work

thank you about help

show the definition of your item and your rule. I think at least that info is required to further help.

@Wolfgang_S i do it with the UI so i don’t have definition file i can put some screen shot at least

sorry about the 3 repplies but i can put only one upload by reply (new user :sweat_smile: )

@Wolfgang_S sometimes the solution is not too far and is a stupid thing :sweat_smile:
i don’t now why the time in docker is 2 hour minus from real time :sob:
i think i need to take a look at my server local time

i trust the time in my habpannel and don’t take care about nas time
i make some try with time needed - 2hrs and that work :rofl:

for people who can have the same isue

you need to write your time zone in EXTRA_JAVA_OPTS " for me -Duser.timezone=Europe/Berlin"

so that

means you just looked at the wrong point in time in the log resp. you did not wait long enough until the entry would have happened because of the wrong timezone ?


The rule is an auto off of my children’s night light (they don’t turn off it on wake up) so it happen too early and my children turn it on again :rofl:

And i search it in the log but at the wrong time

My first experience with cron rule,that make me crazy :joy:
i don t be aware about docker timezone must be set in docker
It was a good exercise :grin: