Schlage FE469NX Won't Connect -- ARGH!

I just installed a Schlage FE469NX Z-Wave lock and for the life of me, I can’t get it to connect fully. It’s driving me batty. I’m using a AEOTEC Gen 5 stick. The lock connected half-way after I first attempted to enroll, and places the device in Things, but when I went to edit the name (Front Door Lock) and location (Home), the PaperUI came back with “Thing Updated”, then “ERROR 500, Internal Server Error”, and the device does not show up on my Home tab on the Control Screen.

The device does show up in HABmin under Things, but again, I can’t seem to access the device.

I did delete it once. It took me a zillion tries to get it back into OpenHab again, but I’m having the same results as the first time. The keypad on the device does not give me the check mark that it’s enrolled, either.

I’m getting extremely aggravated here. I spent $270 specifically to get this to work with my system. I waded through a lot of threads here, but could find no clear answer to how to get this thing to connect properly. Help!

You should try the OH2 Z-Wave refactoring and testing... and SECURITY version of the Z-Wave binding.

It seems that the main unit (BE469) is already in the DB:

Thanks Dim! I’ll give it a try. This one has been so frustrating.

@jjudson Did you ever get the FE469NX working with OpenHab? I’m a noob with OpenHab and also cannot get the lock to do what I expect. When it does pair, it cannot find it in the database/treats it as unknown.

I’m using the org.openhab.binding.zwave-2.3.0-SNAPSHOT binding which I pulled on 3/19 and built to ensure I had the latest. For the controller, I’m using a HomeSeer SmartStick+. Perhaps that’s part of my problem as I haven’t seen any threads using that stick. I’m also running on windows on a pretty fast laptop (while I’m learning/before I commit to a raspberry pi though I shouldn’t imagine that would make a difference.

Would greatly appreciate any insights as I really want to get this working so I can make the jump from SmartThings to OpenHab!

I suspect you are using a version that does not use security. Please see the link above which says that you need to use a specific binding version -:

Thanks @chris
I excluded the lock, deleted all the things, tried using the binding from your link, then re-added the smartstick and discovered the lock via habmin. The logs show everything went well, however the device is still showing up as “Unknown” and I can’t link it to an item.
I’m really hoping this is noob error. I tried to upload logs but I’m a new community user and it won’t allow me.

What does it actually show? There should be some numbers in the name, or at least in the properties it should show the type/id of the device. Without this we can’t check if the device is in the database, or if there’s some other problem.

Even if you are allowed, you can only upload very small files, so you should find somewhere on the web to dump this (github, dropbox, or some other cloud service) and provide the link there.

The device shows up as “Z-Wave Node 011 (003B:6341:5044:128.22)”

The logs are avaialble here:

I’ve also uploaded the node’s xml that was created in userdata/zwave

There’s not a lot in the log -:

This shows that secure inclusion apparently worked ok, but there’s nothing much else in the log.

Actually, I suspect you are using an old version oh OH, and this version is not compatible with the binding (possibly you are on OH2.1?). If so, please upgrade to 2.2 or newer.

Yes - OH 2.1. Didn’t realize there’s a 2.2. I’ll look for it and try that path. Back soon.

Should I completely start from scratch and reset my lock as well?

You shouldn’t need to reset the lock - it looks like it’s probably included ok, but the database can’t be read because it contains information that can only be read in 2.2, and therefore the database files are rejected.

WooHoo! Thanks @chris for your help! Once i got OH 2.2 w/ the latest binding, I excluded the lock and re-added it via habmin and it finally detects the lock properly. I can send lock/unlock commands as well. Now onto learning how to do more with it. Gonna try to learn how to:

  • Set codes via configuration file
  • Some form of automation foo to allow me to create new codes on the fly (via mobile) which are only active for specific date/time ranges

If you know of any threads/advice to point me at I appreciate it. I definitely have a lot of reading/tinkering to do in the mean time.

I think at the moment there is no way to do this - it needs to be done through the UI. It would be posible to use CURL to send a command via the REST interface - it’s a little “hacky”, but it should work.

Guessing the second bullet is similar answer - would need my own service that interact with to provide scheduled changes (activation/deactivation/assignment) of user codes?

Yes - the second point is an extension of the first I guess. I’m not aware of anything that does specifically what you’re after…

Yeah - Want to ultimately have a service which replicates the functionality I’m use to with SmartThings LockManager

I’ve tinkered with SmartThings for a year but I’m more and more disappointed with being dependent on a third party cloud service which when it goes down (for hours) many of my scenes won’t execute.