Sending Alarm frame to Fibaro Dimmer FGD212 not working after updating to OpenHab 2.4


Hi Chris

After updating from OpenHan 2.3.0 to OpenHab 2.4.0 the following does not work anymore:
With the zwave-binding - 2.3.0 I used the following channel to send an Alarm notification to the Dimmer FGD212 (defined in a item-File):

Number EG_Dimmer_Work_lightAlarm “LightAlarm” { channel=“zwave:device:5a658730:node7:notification_send1” }

In a rule I used the following to activate the load blinking for example if a smoke sensor detected a fire:

What do I have to change to activate load blinking again in case of an alarm?

Thank you

Ps. Original post from where I got this idea: ZWave send Alarm frame to Fibaro 212 Dimmer manually via rule or openhab switch

Please be specific about what device you have as there are multiple versions and this channel is not universally configured.

I am not super familiar with this device, so I’m not really sure. Without a log I can’t tell if the binding is sending the command that you set - if you provide a log, I can check that point, but someone else will need to comment on the device specifics.


Here some details about the type of Fibaro Dimmer FGE212 I use:
Hersteller: 010f Fibargroup
Typ-Kennzeichen: 0102:1000
Firmeware-Version 3.5

Here an extract of the log after an alarm event triggering the corresponding rule:
==> /var/log/openhab2/openhab.log <==
2018-12-19 20:08:57.385 [INFO ] [home.model.script.Wasser_Alarm.rules] - Wasser Alarm triggered
2018-12-19 20:08:57.722 [INFO ] [home.model.script.Wasser_Alarm.rules] - Executing sendCommand
==> /var/log/openhab2/events.log <==
2018-12-19 20:08:57.728 [ome.event.ItemCommandEvent] - Item ‘EG_Dimmer_Work_lightAlarm’ received command 1
2018-12-19 20:08:57.735 [nt.ItemStatePredictedEvent] - EG_Dimmer_Work_lightAlarm predicted to become 1

Note: Before upgrading today to OpenHab 2.4 it just worked fine. So I assume something has changed in the new version of the zwave binding or in the database.

Let me know, if and what additional information you need.

Thank you

This version doesn’t seem to have the channel you are trying to use. I don’t think it was removed, so maybe the version numbers changed somewhere…


I do not really understand, what you mean by “maybe the version numbers changed somewhere”.

I looked into my the backup of version 2.3 and found the following for this Dimmer in org.eclipse.smarthome.core.thing.Thing.json:
“acceptedItemType”: “Number”,
“kind”: “STATE”,
“uid”: {
“segments”: [
“channelTypeUID”: {
“segments”: [
“label”: “Send notification”,
“description”: “Sends a notification”,
“configuration”: {
“properties”: {}
“properties”: {
“binding:*:DecimalType”: “ALARM:1;event1\u003dSMOKE:1,event2\u003dACCESS_CONTROL:22,event3\u003dBURGLAR:1,event4\u003dEMERGENCY:1,event5\u003dEMERGENCY:2,event6\u003dEMERGENCY:3”
“defaultTags”: []

So “Send notification” was existing in OpenHab Version 2.3 for my FGD212, version 3.5. And was working fine for me :slight_smile: However after updating to OpenHab Version 2.4 I do not have anymore lines for “Send notification” in org.eclipse.smarthome.core.thing.Thing.json for my FGD212, version 3.5. :frowning:

However I just found, that I have now similar lines for “Send notification” witch OpenHab 2.4 for my DoubleSwitch FGS223 v3.2, which was not available in OpenHab Version 2.3.

What means the column “Ver” in your Device List in the Table “Endpoints”? For both FGD212 and FGS223 there is Send notification" in the section Alarm but for the FGS223 with “Ver 1” and for the FGD212 with “Ver 5” Should that maybe be also “Ver 1” for “FGD212”?

Can I locally add /edit org.eclipse.smarthome.core.thing.Thing.json e.g. add the same code from FGS223 for FGD212? Can I just do it with an editor or is there anything special I should do before editing Thing.json e.g. stop OpenHab first?
Or is there another way I can get this to work again in OpenHab 2.4 for my FGD212? Being for alarming, it is of importance to me to get this working again.

One last wish: SingleSwitch FGS213 V3.2 also supports the same “Send notifications”. However, this is missing in your database. Can you add this feature also for the FGS213. The documentation from Fibaro is the same for FGS223 and FGS213 (Fibaro just writes “FGS-2x3” “Single/Double Switch 2” on there documentation).
I would be great to use “Send notifications” for FGS213, FGS223 and FGD212 as all three do support this feature for reaction on alarm frames “General Alarm”, “Flood Alarm”, “CO/CO2/Smoke Alarm” and “Heat Alarm”.
BTW: Currently, I used / use for FGS213 and FGS223 a work-around with REST API in the rule to change parameter 10 “Operation Mode” to “flashing mode” in case of an alarm. However, this work-around is not available for the dimmer FGD212 :frowning:

Thank you for your help

1 Like

I mean maybe the database versions got changed. There are two versions of this device in the database - given that your version does not have this channel, I suspect that the version was changed so your device now uses the other definition.

As I said - the database does not have this channel (it does now as I added it - but it wasn’t there earlier in the week).

I will update the database tomorrow and you will then be able to use the latest snapshot.

1 Like


Thank you for your fast response and update of the database. :slight_smile:

Can you please also add the "Send notifications” for Fibaro Single Switch FGS213 V3.2 in the database? As written above you have it in the database for Fibaro Double Switch FGS223 but currently not for FGS213. However FGS-2x3 are configuration wise the same as Fibaro has only one manual “FGS-2x3” for both of them.

Thank you

Do you have an account on the database? If not, I’ll add it, but if you have an account then you can also do this?

No, I do not have an account on the database and I also do not know, how to add this to your database. I would therefore appreciate, if you could add this to the database.
Otherwise I would need some information / instructions, how to do it myself.

BTW, at what time tomorrow shall I try to install the latest snapshot to get the database update? And do I have to delete those things of FGD212 in the Paper UI and add it again from the Inbox after the updating to the latest snapshot?

Thank you

I’m not sure - normally late (UK time).

Yes, you will need to delete and re-add so it picks up the new definitions.