Sending text to HM-Dis-WM55

At the moment I try to use a HM-Dis-WM55.
Getting the Buttons does already work. But I am not able to send text to it.
I configured the values like in the sample of the binding.

String Display_line_1 “Line 1” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#DISPLAY_LINE_1” }
String Display_line_3 “Line 3” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#DISPLAY_LINE_3” }
String Display_line_5 “Line 5” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#DISPLAY_LINE_5” }

String Display_color_1 “Color 1” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#DISPLAY_COLOR_1” }
String Display_color_3 “Color 3” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#DISPLAY_COLOR_3” }
String Display_color_5 “Color 5” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#DISPLAY_COLOR_5” }

String Display_icon_1 “Icon 1” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#DISPLAY_ICON_1” }
String Display_icon_3 “Icon 3” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#DISPLAY_ICON_3” }
String Display_icon_5 “Icon 5” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#DISPLAY_ICON_5” }

Switch Button_bottom “Button” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#PRESS_SHORT” }
Switch Display_submit “Submit” { channel=“homematic:HG-HM-Dis-WM55:20e0a1b1:OEQ0103977:1#DISPLAY_SUBMIT” }

My Rule is here
rule "Display Test"
Item Button_bottom received update ON

sendCommand(Arbeitszimmer, ON)
sendCommand(Display_line_1, "Test 1")
sendCommand(Display_line_5, "Test 5")

sendCommand(Display_icon_1, "NONE")
sendCommand(Display_icon_3, "OPEN")
sendCommand(Display_icon_5, "INFO")

sendCommand(Display_color_1, "NONE")
sendCommand(Display_color_3, "RED")
sendCommand(Display_color_5, "BLUE")

sendCommand(Display_submit, ON)


So the rule gets triggered cause my Light “Arbeitszimmer” switches to on. But I only get “Keine Daten Empfangen” - “No Data received” at the HM-Dis-WM55

Any help is much appreciated

Hi Mario,

I have got the HM-Dis-EP-WM55 display which is a bit different but both devices are handled by the same implementation in the binding.
The display is a bit problematic and if the message sent to the device is not absolutely correct the device reacts with an error message (you should also check whether the CCU shows some error messages for the device). In my first tests I even had to restart the CCU some times …
The rule looks find to me but as far as I remember the device seems to have a problem if a message is sent too fast after a button press event. For a test you could try to a sleep command to your rule.
If this does not help you should enable the debug log logs for the Homematic binding.

BTW which openHAB version are you using?

Hi Martin,

thanks for your help. I added a sleep without solving the issue. I use Openhab 2.1 with homegear as a CCU

Did you try to send only text without settings icons and colors?
Maybe there is also a problem that is caused by Homegear (just guessing).

Yes. Also tried only one line of text.

Do you see any information in the openHAB log? The debug or trace log should give at least some more information.
Hmmm, maybe @gerrieg has an idea.

No I dont get an error. The device seems to work as I get the button pressed action

Did you check the homegear log?

If you are running openHABian you can make the homegear log easily accessible via frontail.

Hi Joachim,

I added your modification and checked the log in frontail. All looks normal but I still get “Keine Daten empfangen”

2017-12-09 12:34:42.019 [GroupItemStateChangedEvent] - gLicht changed from OFF to ON through Arbeitszimmer
2017-12-09 12:34:42.052 [ItemCommandEvent ] - Item ‘Arbeitszimmer’ received command ON
2017-12-09 12:34:43.855 [ItemCommandEvent ] - Item ‘Display_line_1’ received command Hallo
2017-12-09 12:34:43.863 [ItemCommandEvent ] - Item ‘Display_line_5’ received command Welt
2017-12-09 12:34:43.868 [ItemStateChangedEvent ] - Display_line_1 changed from NULL to Hallo
2017-12-09 12:34:43.873 [ItemCommandEvent ] - Item ‘Display_icon_1’ received command OPEN
2017-12-09 12:34:43.880 [ItemStateChangedEvent ] - Display_line_5 changed from NULL to Welt
2017-12-09 12:34:43.888 [ItemStateChangedEvent ] - Display_icon_1 changed from NULL to OPEN
2017-12-09 12:34:43.888 [ItemCommandEvent ] - Item ‘Display_icon_3’ received command OPEN
2017-12-09 12:34:43.907 [ItemStateChangedEvent ] - Display_icon_3 changed from NULL to OPEN
2017-12-09 12:34:43.910 [ItemCommandEvent ] - Item ‘Display_icon_5’ received command INFO
2017-12-09 12:34:43.924 [ItemStateChangedEvent ] - Display_icon_5 changed from NULL to INFO
2017-12-09 12:34:43.927 [ItemCommandEvent ] - Item ‘Display_color_1’ received command RED
2017-12-09 12:34:43.935 [ItemCommandEvent ] - Item ‘Display_color_3’ received command RED
2017-12-09 12:34:43.938 [ItemStateChangedEvent ] - Display_color_1 changed from NULL to RED
2017-12-09 12:34:43.945 [ItemCommandEvent ] - Item ‘Display_color_5’ received command BLUE
2017-12-09 12:34:43.949 [ItemStateChangedEvent ] - Display_color_3 changed from NULL to RED
2017-12-09 12:34:43.964 [ItemStateChangedEvent ] - Display_color_5 changed from NULL to BLUE
2017-12-09 12:34:43.965 [ItemCommandEvent ] - Item ‘Display_submit’ received command ON
2017-12-09 12:34:43.977 [ItemStateChangedEvent ] - Display_submit changed from OFF to ON

That’s still the openHAB log, you need to point your browser to port 9002 instead of 9001 to watch the Homegear log.

Sorry. I am quite new to OpenHab

12/09/17 13:27:10.823 Module HomeMatic BidCoS: HM-MOD-RPI-PCB “My-HM-MOD-RPI-PCB”: Info: Sending (My-HM-MOD-RPI-PCB): 0E3FA011FDEF595619410201C80000
12/09/17 13:27:11.152 HomeMatic BidCoS packet received (My-HM-MOD-RPI-PCB, RSSI: -74 dBm): 0E3F8002561941FDEF590101C80050
12/09/17 13:27:11.152 Module HomeMatic BidCoS: Info: Queue 5 is empty and there are no pending queues.
12/09/17 13:27:11.153 Module HomeMatic BidCoS: Info: STATE on channel 1 of HomeMatic BidCoS peer 2 with serial number NEQ1831603 was set to 0xC8.
12/09/17 13:27:11.153 Module HomeMatic BidCoS: Info: WORKING on channel 1 of HomeMatic BidCoS peer 2 with serial number NEQ1831603 was set to 0x00.
12/09/17 13:27:12.920 RPC Server (Port 2001): Info: Client number 162 is calling RPC method: setValue (2) Parameters:
(String) OEQ0103977:1
(String) SUBMIT
(String) 0x02,0x0a,0x12,0x48,0x61,0x6c,0x6c,0x6f,0x11,0x81,0x13,0x82,0x0a,0x12,0x20,0x11,0x80,0x0a,0x12,0x20,0x11,0x81,0x13,0x82,0x0a,0x12,0x20,0x11,0x80,0x0a,0x12,0x57,0x65,0x6c,0x74,0x11,0x85,0x13,0x86,0x0a,0x03
12/09/17 13:27:15.133 RPC Server (Port 2001): Info: Connection from ::ffff: accepted. Client number: 196
12/09/17 13:27:15.134 RPC Server (Port 2001): Info: RPC server client id for client number 196 is: 101
12/09/17 13:27:21.370 RPC Server (Port 2001): Info: Client number 162 is calling RPC method: listBidcosInterfaces (2) Parameters:

This doesn’t look like an error. Did you check the Homegear forum?

Thanks. Will try it there