Serial Error: Port ttyACM0 does not exist z wave stick rpi paper UI

Hey, ive been stuck on this for a few hours trying to add my zwave stick to a new install of openhabian

I have in paper UI gone to configure the addon by adding a “thing” but when I try to add the serial port as:


it says that it is offline.

I read somewhere that I need to ensure that the pi is a member of the dialout group and confirmed that it was.

I am pretty sure this is where my zwave stick is plugged in to my RPI2, as this is the port that disconnects when i remove the stick.

I have had this zwave network up and running in the past using domoticz and even using an older version of habmin so am a bit confused on where to go next.

i also have /dev/ttyAMA0 but am sure it is not connected to this one. Unless it is? I am a bit stumped on what to do next.

It is an Aeon labs 5th Gen

I think there are already a number of threads that probably relate to this -:

Hey Chris I read that first post you linked but I couldn’t see any reply. Is this most likely that the user pi doesn’t have permission to access the USB serial port?

Related thread:

Hello everbyody,

i just updated my openhab 2 and had the same issue after the update finished (running openhab on a PI2). I searched the net and stumpled over Issue #60 on the nrjavaserial github project. It’s about a change for creating lock files in the correct folder, which was introduced in 3.12.0

So i installed the library “liblockdev” (sudo apt-get install liblockdev1) mentioned in the thread above and restarted openhab and my zwave controller is now online again!


worked for me too (PI3)

That fixed it! Ill have a read on what the library liblockdev actually does…

Worked for me too on a new pi3 + openHABian. Will be watching posts to see if this is the “permanent” fix.

The serial lib change has been reverted recently. The next build should use the old nrjavaserial package again.