Serial port option RFXCOM USB Transceiver not shown

Tags: #<Tag:0x00007efebb4d5650>
  • Platform information: OpenHAB 2.5.0.000
  • Hardware: Synology DS716+II running DSM 6.2.2-24922 update 4
  • Issue of the topic: please be detailed explaining your issue:
    I just started with OpenHAB after using a few years Domoticz. I stoped with Domoticz because it is not stable enough. So I installed Friday OpenHAB. Installation went ok and the Z-Wave Serial Controller is working and connected to serial port /dev/ttyACM0 Only option shown). This is the port on the front of the Synology. I’m not able to select the correct port for the RFXCOM USB Transceiver (connected at the bottom USB connector on the backside). There is only one option shown for the serial port and that is the same port as used for Z-Wave. The command lsusb -ciu shows that the RFXCom is connected to ttyUSB0 but that option is not shown. I search and found a lot of tips to change some files like /etc/udev/rules.d/ and /etc/default/openhab2 to fix this issue but the problem I have that those files don’t exit on my system. What to do to fix this?
    Thanks

Hi @HenMus,

Were you able to fix your issue? I also decided to move away from Domoticz and install OpenHAB 2.5.2

Cheers

The documentation might be of help here:

thanks @hilbrand
I decided to step away from the direct OH installation on Synology DS920+
Instead I’m now running it in docker; OH versio 2.5.11

I managed to get RFXCOM USB Transceiver working. :slight_smile:
However it some point it times out: and log shows:

Connection to RFXCOM transceiver failed org.eclipse.smarthome.io.transport.serial.PortInUseException: null
Any clue?

Also looking desperately to have RFLink working.
Trying version 2.3.0, from GitHub - cyrilcc/org.openhab.binding.rflink: RFLink binding for OpenHAB 2.0. But not able to configure the thing. In manually adding screen, the serial port is not giving me the option in the drop down.
I have RFXCOM (/dev/ttyUSB1) and RFLink (/dev/ttyUSB0).

Any suggestions?

Happy holidays!

The times I saw an error about port in use was when the binding didn’t correctly close a connection. And when I was updating either the binding/configuration the port was still locked and thus could not be used by the updated binding/configuration. There might possible be some linux command to free the port, but I only know that a reboot will free the port.

Looking at the source code you linked to. The rflink binding thing definition is missing the information (context is serial) so the user interface doesn’t know it should show a list of serial ports. This can only be fixed in the binding.

Regarding rflink binding see also: https://community.openhab.org/t/rflink-binding

Thanks for your reply Hilbrand.
I got it to work, turns out that I did not get a drop down, but manually typing the serial port /dev/ttyUSB0 as the entry solved my issue :slight_smile: