Serial ports issue

I’ve managed to get my Zwave and Enocean binding working in isolation however, when I attempt to use both I run into problems. If I run Openhab from the command line with “sudo sh ./” Enocean works fine but I get an error in the logs stating that “/dev/ttyAMA0” does not exist. It does exist.

If I run openhab via “sudo service openhab start” Zwave works fine but no Enocean events are received and there is nothing about Enocean logged at all. The service is configured to run as root.

Root is a member of dialout.

Any ideas? I’m thinking its permissions but I don’t see how since root is a member of dialout and sudo essentially runs as root I believe.


There was a serial port conflict between the Z-Wave and Insteon bindings, and a fix to the Insteon binding seemed to have corrected the issue. That may be unrelated, but a question is if there is a conflict between the EnOcean and Z-Wave port opening code.

Ok, I’m almost certain that this is the same issue as the Instead binding issue mentioned above. That issue alludes to a fix that would work for all serial port bindings. However, I can’t find a record of it. Does anyone know if a fix for multiple binding that use serial ports has made it into a release or is targeted for a future release?