Set offset for temperature

Hi,

I have a system for sending temperatures and humidity via mqtt, I wanted to set an offset via the profile, but it doesn’t work, do you have any advice?
thanks

Number   FF_FamilyRoom_Temperature      "Family Room Temperature [%.1f °C]"   			    <temperature> (FF_FamilyRoom, g_FF_Boiler_TSTAT, AVG_Temperature)  					        {channel="mqtt:topic:temperature:temperatura_soggiorno" [profile="offset", offset="10"], ga="thermostatTemperatureAmbient" }

Profile is applied at channel link, thus you need to look there. I recall there was gain offset profile in modbus binding and math transformation provided by smarthomej (third party addons).

It should work in the way you wish. What happens instead?
You would need to apply to a number type channel, and the channel should be issuing a number update (not a quantity, with units).

in the sitemaps does not display the changing temperature

now i tried to edit like this but it doesn’t work
thanks

Number:Temperature   FF_Kitchen_Temperature         "Kitchen Temperature [%.1f%°C%]"     			 <temperature>   (FF_Kitchen, gTemperature, AVG_Temperature)     					        {channel="mqtt:topic:temperature:temperatura_cucina" [profile="offset", offset="10 |°C"]}

Don’t just try stuff at random, it won’t help.
What is the MQTT channel type?
Is that giving you a number or quantity (with units) update? You’d choose your offset to match. And your Item type.

That’s a bit messed up, maybe it affects your display

Look at your events.log to see what the Item gets updated to, which gets around any display issues. Look back to see what it was doing before your latest edit.

1 Like

yes you are right, the mqtt channel is this, it should be a number

on the events.log file is not logging, I try to enable logs

Thing mqtt:topic:temperature {
    Channels:
	Type number : temperatura_cucina "FF_Kitchen_Temperature" [stateTopic="home/cucina/temperatura" ]
	Type number : temperatura_soggiorno "FF_FamilyRoom_Temperature" [stateTopic="home/soggiorno/temperatura" ]

Okeydoke, it is a number type channel and there appear to be no units involved.
Change your Item back the way it was to begin with.

When you’ve got stuff how you want it, try a reboot, because file-based edits of links and Item sub-types and and the like are not very interactive and old setups linger.

perfect works, just restart

thanks

1 Like