Set up Nest binding with Google Device Access?

  • Platform information:
    • Hardware: RaspberryPi3
    • OS: OpenHABian
    • openHAB version: 3.0.2

I am trying to set up a Raspberry Pi to run OpenHABian and integrate with some Nest thermostats. I’m following the setup instructions at Adding Things - Simple | openHAB, and am stuck at the step to create a Nest Binding. The documentation for setting up a binding (Nest - Bindings | openHAB) seems to be from before Google bought Nest and retired the old Nest platform. I tried creating a Google Device Access account (and already paid the $5 registration fee), assuming that I would get the necessary info, but I don’t see the required binding information in the Google Device Access Console. The OpenHAB binding form is asking for a “Product ID”, “Product Secret”, and a “Pincode”. The only thing that the Google Device Access Console gives me is a “Project ID”, a “Pub/Sub topic”, and a field to enter an “OAuth client ID”. I’m not sure what to do with any of this information. I’m new to the whole nest API thing, and also to OAuth, so I’m kind of at a loss as to how to proceed.

Is it possible to set up a Nest binding with OpenHAB using the new Google API? If so, is there documentation for setting up the bindings and adding the thermostats? I tried looking, but didn’t find anything.

Thanks in advance for any help.

Have a look to this post and the thread it belongs to: Google Nest Device Access Console now available - #260 by wborn

That’s very helpful. Thank you.
However, while following the README instructions, I’m not seeing “Nest SDM Account” as an available option for a Thing in the OpenHAB portal. (See the 3rd subsection in “SDM Configuration Parameters” in openhab-addons/ at ee410fe865fe9bd0759abe774acf7d944e8477ff · wborn/openhab-addons · GitHub).

I only have “Nest Account” as an available option. I tried going to “Install More Bindings”, but I do not see “Nest SDM Account” (or any other additional Nest bindings) in the list of bindings that can be installed.

As far as I can see you are on OH 3.0.2. Did you install the snapshot jar file or did you install the binding via the UI ? According to Google Nest Device Access Console now available - #283 by wborn :

To use the SDM API with OH 3.0.2, uninstall the 3.0.2 Nest Binding in openHAB and add the 3.0.3-SNAPSHOT JAR to your /addons directory @hdr_jgrade.

For the JAR see:


Thanks again for the responses @Wolfgang_S and @wborn. I followed the instructions for installing the 3.0.3 add-on by logging into Putty and executing the commands in the following thread:

I ran the wget and chown commands as described, and the 3.0.3 file is downloaded into the directory.

However, I still do not see the 3.0.3 bindings in the list of available add-ons. The list of available add-ons still only shows 3.0.2 as available to be installed. The above thread seems to be referring to OpenHAB2, but I guess I only have OpenHAB 1, so I don’t see a openhab2-conf\services\addons.cfg file.

Are there additional steps for installing/registering the add-on after it has been downloaded? Do I have to reboot the RPi or logout/re-login to the OpenHAB portal in order for the new add-on to be recognized?

If you sideload addons they are always installed automatically. So they won’t show in the addons list but it should be possible to add an SDM Account Thing. You can now also upgrade to openHAB 3.1, which was recently released, so it will all work as usual.

1 Like