Setting Up openHAB on a Synology ds415+

Hallo

I’m trying to get the OpenHAB system running on my system.
After installing Java 1.17.0_51 I installed OpenHAB in all Versions from 1.5 until 1.8 and i tried the Demos 1.5 and 1.8 from your website.

But i always get the Same error:
Problem accessing /openhab.app. Reason:
Sitemap ‘demo’ could not be found
Caused by:
org.openhab.ui.webapp.render.RenderException: Sitemap ‘demo’ could not be found at org.openhab.ui.webapp.internal.servlet.WebAppServlet.service(WebAppServlet.java:115)

A few hints were to update the Directory permissions, but this didn’t help, too.
I hope you have someone ideas.

Herb

Where did you put the demo sitemap in the synology file system?
I have my config files in @appstore/OpenHAB/ on my ds415+.

Hello marklavercombe,
Thanks for your fast Reply on my topic.

Both subfolders (addons & configurations) are in /volume1/public/OpenHAB/
I read that there was a problem with the structure, therefor I used the default.

Herb

I have them in volume1/@appstore/OpenHAB/ which is where they defaulted to, and it works well.

Maybe try moving and see if works…

It took me a day to copy the directories.
Created a new folder appstore and then used mount to map the directory /volume1/@appstore/ with /volume1/appstore/
Then I updated the ownership to openhab.
Finally I renamed the folder /volume1/public/OpenHAB/ to be sure.

After a restart of the service, the same occured. Even on a new browser.

Herb