Setting wifi as hotspot

I would like to ask about an issue i’m having with openhabian and not with raspbian Stretch.
well by following this guide

i could setup my wifi without a problem but in openhabian i got an issue when i try to restart the dhcpd using this command:
sudo service dhcpcd restart

What issue? Please be a bit more specific

Openhabian uses the newer ‘systemd’ based init, so the service command is depricated and replaced by systemctl. Please try:

sudo systemctl restart dphcp

Note that the command (restart) and the service name (dhcpd) are swapped.

still gettinh the same error
Warning: dhcpcd.service changed on disk. Run ‘systemctl daemon-reload’ to reload units.
Job for dhcpcd.service failed because the control process exited with error code.
See “systemctl status dhcpcd.service” and “journalctl -xe” for details.

i figured it out thanks everybody :slight_smile:

Please post how you figured it out so future readers who have the same problem know what to do.

1 Like

Well it depends, cause ppl were having the same error but for different reasons so i had to read the journal with this command

journalctl -xe

and it was saying that it didnt find any interface to start the dhcp on its a little bit missleading as an error cause the main reason is that we disabled the wpa.supplicant but the wlan0 was still on autohotplug
so i had to clear the /etc/network/interface file from any interface then stop the 2 services hostapd and dnsmasq to avoid any future confusion and restart the dhcp so it worked like a charm.