Setup HUSBZB-1 (EMBER EM35x Coordinator) Help Please

binding
Tags: #<Tag:0x00007fd30c2adfc8>

(Scott Rushworth) #61

Oops… it’s in there now!


(Michel Lesoinne) #62

I now have:

216 │ Active   │  80 │ 1.0.13                 │ com.zsmartsystems.zigbee
217 │ Active   │  80 │ 1.0.13                 │ com.zsmartsystems.zigbee.dongle.ember
218 │ Active   │  80 │ 2.4.0.201807081945     │ ZigBee Binding
219 │ Active   │  80 │ 2.4.0.201807081945     │ ZigBee Ember Binding

Is that what you have as well?


(Scott Rushworth) #63

280 │ Active │ 80 │ 1.0.13 │ com.zsmartsystems.zigbee
281 │ Active │ 80 │ 1.0.13 │ com.zsmartsystems.zigbee.dongle.ember
284 │ Active │ 80 │ 2.4.0.201807081945 │ org.openhab.binding.zigbee.ember
285 │ Active │ 80 │ 2.4.0.201807081945 │ org.openhab.binding.zigbee

Twins!


(Michel Lesoinne) #64

Finally, after removing, resetting the bulbs themselves and then re-discovering, they now work again. I hope it will all work better now.
Thanks once again, @5iver for your help.


(Scott Rushworth) #65

This version of the binding definitely works better for Ember coordinators than the release version, but I still have bulbs dropping occasionally. They are pretty crumby bulbs, but GE sent me replacements under warranty, so I have lots of spare crumby bulbs. :roll_eyes:


(Sam B.) #66

I recommend a 6’ USB extension cable to keep the usb device further away. I’m using the Raspberry Pi and doing this, and is all working very well.

Remove the thing, then perform a reset as per the manufacturer’s manual instructions for that device.

CdJackson told me it (Zigbee binding) should be Hardware Control, and set the baud rate to 57600. It has been working perfectly for me. You’ll find when setting to “software control” your zigbee devices will not work.

Yes, that too worked for me. Once reset and paired with this coordinator, it should “remember” going forward.


(Scott Rushworth) #67

You are probably using different hardware. For this device, HUSBZB-1, flow control should be set to software. Myself and others with the HUSBZB-1 are using it this way, and it is definitely working. It’s also specified in the documentation…


(Sam B.) #68

I’m using the HUSBZB-1, too.


(Scott Rushworth) #69

Based on the documentation and other posts, I’m guessing @chris misstated the flow control setting in this post…


(Sam B.) #70

@5iver, I see. Since I’ve had it set to Hardware Control without issues, what do you advise?


(Scott Rushworth) #71

When the flow control was first added, It defaulted to hardware, and everything seemed to be working for me. When asked which to use, @chris suggested software, so I’d suggest to use the same. :slight_smile:


(Chris Jackson) #72

Correct - it should be XON//OFF flow control when running at 57600 and RTS//CTS when running at 115200.

Generally, for the slower speed it doesn’t matter, which is why for the HUSBZB it probably isn’t making any difference - for the higher speed, it does matter and needs to be set correctly or the Ember coordinator won’t work.


(Michel Lesoinne) #73

I have put a 3’ USB extension cable, moved the box away from the WiFi and also upgraded my linux version. I am not sure if the latter does help, but after a reboot and turning off and on the lights, both lightbulbs reconnected after a few minutes and are operable.

Let’s hope it stays that way.


(Sam B.) #74

FYI: When I set the Ember coordinator to RTS/CTS at 115200 baud, it never comes online. Restarting OpenHAB and waiting also does not make it come online. I’ve found 5700 baud is the only setting that makes it comes online.


(Chris Jackson) #75

Correct - the HUSBZB will ONLY work at 57600 unless the firmware is changed. Sorry if I confused you earlier - my comment was relating to Ember coordinators where there are two different firmware versions - one running at 57600 with XON//OFF, and another running at 115200 with RST//CTS. Depending on the firmware that is running in your device, you must use the correct setting.